source: branches/fc13-dev/server/fedora/specs/zephyr.spec @ 1637

Last change on this file since 1637 was 1635, checked in by ezyang, 14 years ago
Fix rpmlint and Anders complaints.
File size: 2.1 KB
Line 
1Name:           zephyr
2Version:        3.0
3Release:        1.%{scriptsversion}%{?dist}
4Summary:        Zephyr allows users to send messages to other users or to groups of users.
5
6Group:          Applications/Communications
7License:        MIT
8URL:            http://zephyr.1ts.org/
9Source0:        http://zephyr.1ts.org/export/HEAD/distribution/%{name}-%{version}.tar.gz
10Source1:        zhm.init
11BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12
13BuildRequires:  krb5-devel hesiod-devel libss-devel readline-devel bison
14Requires(post): chkconfig
15Requires(preun): chkconfig
16Requires(preun): initscripts
17Requires(postun): initscripts
18
19%description
20Zephyr is an institutional/enterprise-scale distributed real-time messaging and
21notification system.  Zephyr's design choices seem to imbue it with a specific
22culture.  It is impossible to explain what Zephyr is, you must experience it
23for yourself.
24
25
26%prep
27%setup -q
28cp -p %{SOURCE1} .
29
30
31%build
32# Mitch wants to make an awesome specfile which makes hesiod/krb5 and friends
33# all fully configurable.  This configure line will have to do for now.
34%configure --with-hesiod --with-krb5
35sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
36sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
37make %{?_smp_mflags}
38
39
40%install
41rm -rf $RPM_BUILD_ROOT
42make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_libdir}
43
44mkdir -p $RPM_BUILD_ROOT%{_initddir}
45install -m755 zhm.init \
46        $RPM_BUILD_ROOT%{_initddir}/zhm
47
48
49%post
50/sbin/chkconfig --add zhm
51
52
53%preun
54if [ $1 = 0 ] ; then
55    /sbin/service zhm stop >/dev/null 2>&1
56    /sbin/chkconfig --del zhm
57fi
58
59
60%postun
61if [ "$1" -ge "1" ] ; then
62    /sbin/service zhm condrestart >/dev/null 2>&1 || :
63fi
64
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69
70%files
71%defattr(-,root,root,-)
72%doc README NOTES OPERATING USING
73%{_bindir}/*
74%{_sbindir}/*
75%{_includedir}/%{name}/
76%{_libdir}/*
77%{_mandir}/man1/*
78%{_mandir}/man8/*
79%{_datadir}/%{name}/
80%{_sysconfdir}/%{name}/
81%{_initddir}/zhm
82
83
84%changelog
85* Thu Sep 09 2010 Edward Z. Yang <ezyang@mit.edu> 3.0-1
86- Initial packaging release, superseding mit-zephyr.
Note: See TracBrowser for help on using the repository browser.