source: branches/fc13-dev/server/fedora/specs/zephyr.spec @ 1633

Last change on this file since 1633 was 1633, checked in by ezyang, 14 years ago
Package zephyr for Fedora 13. This deprecates mit-zephyr.
File size: 2.1 KB
Line 
1Name:           zephyr
2Version:        3.0
3Release:        1.%{scriptsversion}%{?dist}
4Summary:        Zephyr allows users to send messages to other users or to groups of users.
5
6Group:          Applications/Communications
7License:        MIT
8URL:            http://zephyr.1ts.org/
9Source0:        http://zephyr.1ts.org/export/HEAD/distribution/%{name}-%{version}.tar.gz
10Source1:        zhm.init
11BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12
13BuildRequires:  krb5-devel hesiod-devel libss-devel readline-devel bison
14Requires(post): chkconfig
15Requires(preun): chkconfig
16Requires(preun): initscripts
17Requires(postun): initscripts
18
19%description
20Zephyr is an institutional/enterprise-scale distributed real-time messaging and
21notification system.  Zephyr's design choices seem to imbue it with a specific
22culture.  It is impossible to explain what Zephyr is, you must experience it
23for yourself.
24
25
26%prep
27%setup -q
28
29
30%build
31# Mitch wants to make an awesome specfile which makes hesiod/krb5 and friends
32# all fully configurable.  This configure line will have to do for now.
33%configure --with-hesiod=%{_usr} --with-krb5=%{_usr}
34sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
35sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
36make %{?_smp_mflags}
37
38
39%install
40rm -rf $RPM_BUILD_ROOT
41make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_libdir}
42
43mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
44install -m755 $RPM_SOURCE_DIR/zhm.init \
45        $RPM_BUILD_ROOT/etc/rc.d/init.d/zhm
46
47
48%post
49/sbin/chkconfig --add zhm
50
51
52%preun
53if [ $1 = 0 ] ; then
54    /sbin/service zhm stop >/dev/null 2>&1
55    /sbin/chkconfig --del zhm
56fi
57
58
59%postun
60if [ "$1" -ge "1" ] ; then
61    /sbin/service zhm condrestart >/dev/null 2>&1 || :
62fi
63
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68
69%files
70%defattr(-,root,root,-)
71%doc README NOTES OPERATING USING
72%{_bindir}/*
73%{_sbindir}/*
74%{_includedir}/%{name}/
75%{_libdir}/*
76%{_mandir}/man1/*
77%{_mandir}/man8/*
78%{_datadir}/%{name}/
79%{_sysconfdir}/%{name}/
80%{_sysconfdir}/rc.d/init.d/zhm
81
82
83%changelog
84* Thu Sep 09 2010 Edward Z. Yang <ezyang@mit.edu> 3.0-1
85- Initial packaging release, superseding mit-zephyr.
Note: See TracBrowser for help on using the repository browser.