source: branches/fc13-dev/server/fedora/specs/httpd.spec.patch @ 1635

Last change on this file since 1635 was 1615, checked in by xavid, 12 years ago
Update spec patchs for f13.
File size: 2.4 KB
RevLine 
[1615]1--- httpd.spec.orig     2010-07-27 11:55:33.000000000 -0400
2+++ httpd.spec  2010-09-06 20:45:28.000000000 -0400
[1259]3@@ -7,7 +7,7 @@
[926]4 Summary: Apache HTTP Server
5 Name: httpd
[1615]6 Version: 2.2.16
7-Release: 1%{?dist}
8+Release: 1%{?dist}.scripts.%{scriptsversion}
[926]9 URL: http://httpd.apache.org/
10 Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
11 Source1: index.html
[1602]12@@ -55,6 +55,14 @@
[1]13 Conflicts: pcre < 4.0
[1259]14 Requires: httpd-tools = %{version}-%{release}, apr-util-ldap
[1]15 
[925]16+Provides: scripts-httpd
[1]17+Patch1000: httpd-suexec-scripts.patch
[795]18+Patch1003: httpd-2.2.x-mod_status-security.patch
[1035]19+Patch1004: httpd-2.2.x-304.patch
[1348]20+Patch1005: httpd-2.2.x-mod_ssl-sessioncaching.patch
[1356]21+Patch1006: httpd-suexec-cloexec.patch
[1602]22+Patch1007: httpd-fixup-vhost.patch
[1]23+
24 %description
25 The Apache HTTP Server is a powerful, efficient, and extensible
26 web server.
[1607]27@@ -65,6 +73,7 @@
28 Obsoletes: secureweb-devel, apache-devel, stronghold-apache-devel
29 Requires: apr-devel, apr-util-devel, pkgconfig
30 Requires: httpd = %{version}-%{release}
31+Provides: scripts-httpd-devel
32 
33 %description devel
34 The httpd-devel package contains the APXS binary and other files
[1615]35@@ -103,6 +112,7 @@
[925]36 Requires(post): openssl >= 0.9.7f-4, /bin/cat
[1499]37 Requires(pre): httpd
[925]38 Requires: httpd = 0:%{version}-%{release}, httpd-mmn = %{mmn}
39+Provides: scripts-mod_ssl
40 Obsoletes: stronghold-mod_ssl
41 
42 %description -n mod_ssl
[1615]43@@ -130,6 +140,13 @@
[1]44 # Patch in vendor/release string
45 sed "s/@RELEASE@/%{vstring}/" < %{PATCH20} | patch -p1
46 
47+%patch1000 -p1 -b .scripts
[795]48+%patch1003 -p1 -b .permitstatus
[1035]49+%patch1004 -p1 -b .scripts-304
[1348]50+%patch1005 -p1 -b .ssl-sessioncache
[1356]51+%patch1006 -p1 -b .cloexec
[1602]52+%patch1007 -p1 -b .fixup-vhost
[1]53+
54 # Safety check: prevent build if defined MMN does not equal upstream MMN.
55 vmmn=`echo MODULE_MAGIC_NUMBER_MAJOR | cpp -include include/ap_mmn.h | sed -n '/^2/p'`
56 if test "x${vmmn}" != "x%{mmn}"; then
[1615]57@@ -178,10 +195,12 @@
[684]58         --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
59        --enable-suexec --with-suexec \
60        --with-suexec-caller=%{suexec_caller} \
61-       --with-suexec-docroot=%{contentdir} \
[1288]62+       --with-suexec-docroot=/ \
[684]63+       --with-suexec-userdir=web_scripts \
[824]64+       --with-suexec-trusteddir=/usr/libexec/scripts-trusted \
[684]65        --with-suexec-logfile=%{_localstatedir}/log/httpd/suexec.log \
66        --with-suexec-bin=%{_sbindir}/suexec \
67-       --with-suexec-uidmin=500 --with-suexec-gidmin=100 \
68+       --with-suexec-uidmin=50 --with-suexec-gidmin=50 \
69         --enable-pie \
70         --with-pcre \
71        $*
Note: See TracBrowser for help on using the repository browser.