X-Git-Url: https://scripts.mit.edu/gitweb/autoinstalls/wordpress.git/blobdiff_plain/ae01624bdce6b71c47e08e8a0287de58284a6b73..72836ec95a52eacbda4dc5aa296b7dd6de08bd3b:/wp-admin/upgrade.php diff --git a/wp-admin/upgrade.php b/wp-admin/upgrade.php index 794b55b6..24fe9760 100644 --- a/wp-admin/upgrade.php +++ b/wp-admin/upgrade.php @@ -15,7 +15,9 @@ define( 'WP_INSTALLING', true ); /** Load WordPress Bootstrap */ -require( '../wp-load.php' ); +require( dirname( dirname( __FILE__ ) ) . '/wp-load.php' ); + +nocache_headers(); timer_start(); require_once( ABSPATH . 'wp-admin/includes/upgrade.php' ); @@ -27,7 +29,7 @@ if ( isset( $_GET['step'] ) ) else $step = 0; -// Do it. No output. +// Do it. No output. if ( 'upgrade_db' === $step ) { wp_upgrade(); die( '0' ); @@ -38,11 +40,14 @@ $step = (int) $step; $php_version = phpversion(); $mysql_version = $wpdb->db_version(); $php_compat = version_compare( $php_version, $required_php_version, '>=' ); -$mysql_compat = version_compare( $mysql_version, $required_mysql_version, '>=' ) || file_exists( WP_CONTENT_DIR . '/db.php' ); +if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) ) + $mysql_compat = true; +else + $mysql_compat = version_compare( $mysql_version, $required_mysql_version, '>=' ); @header( 'Content-Type: ' . get_option( 'html_type' ) . '; charset=' . get_option( 'blog_charset' ) ); ?> - + > @@ -52,14 +57,14 @@ $mysql_compat = version_compare( $mysql_version, $required_mysql_version, '>=' wp_admin_css( 'ie', true ); ?> - -

WordPress

+ +

-

+

='

-

+

-

+