X-Git-Url: https://scripts.mit.edu/gitweb/autoinstalls/wordpress.git/blobdiff_plain/11be15bd505d66a91e2c80062190b13e315a04a9..3194d1bb103c2d8db4f44feeced5e58ee2756658:/wp-admin/upgrade.php diff --git a/wp-admin/upgrade.php b/wp-admin/upgrade.php index b0428773..03940b01 100644 --- a/wp-admin/upgrade.php +++ b/wp-admin/upgrade.php @@ -15,7 +15,7 @@ define( 'WP_INSTALLING', true ); /** Load WordPress Bootstrap */ -require( '../wp-load.php' ); +require( dirname( dirname( __FILE__ ) ) . '/wp-load.php' ); nocache_headers(); @@ -35,6 +35,14 @@ if ( 'upgrade_db' === $step ) { die( '0' ); } +/** + * @global string $wp_version + * @global string $required_php_version + * @global string $required_mysql_version + * @global wpdb $wpdb + */ +global $wp_version, $required_php_version, $required_mysql_version; + $step = (int) $step; $php_version = phpversion(); @@ -50,7 +58,9 @@ else > + + <?php _e( 'WordPress › Update' ); ?> -

+ -

+

WordPress %1$s requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $wp_version, $required_php_version, $required_mysql_version, $php_version, $mysql_version ); + printf( __('You cannot update because WordPress %1$s requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $wp_version, $required_php_version, $required_mysql_version, $php_version, $mysql_version ); elseif ( !$php_compat ) - printf( __('You cannot update because WordPress %1$s requires PHP version %2$s or higher. You are running version %3$s.'), $wp_version, $required_php_version, $php_version ); + printf( __('You cannot update because WordPress %1$s requires PHP version %2$s or higher. You are running version %3$s.'), $wp_version, $required_php_version, $php_version ); elseif ( !$mysql_compat ) - printf( __('You cannot update because WordPress %1$s requires MySQL version %2$s or higher. You are running version %3$s.'), $wp_version, $required_mysql_version, $mysql_version ); + printf( __('You cannot update because WordPress %1$s requires MySQL version %2$s or higher. You are running version %3$s.'), $wp_version, $required_mysql_version, $mysql_version ); ?> -

+

-

-

+

+

-

+