]> scripts.mit.edu Git - autoinstalls/wordpress.git/blobdiff - wp-admin/update-core.php
Wordpress 2.8.5-scripts
[autoinstalls/wordpress.git] / wp-admin / update-core.php
index 1f45824216e580fe1105195f072eeac60cc08c06..5bd44c7a9e744b1016653ef828b27a4f7df3c835 100644 (file)
@@ -14,7 +14,7 @@ if ( ! current_user_can('update_plugins') )
 
 function list_core_update( $update ) {
        global $wp_local_package;
 
 function list_core_update( $update ) {
        global $wp_local_package;
-       $version_string = 'en_US' == $update->locale ?
+       $version_string = ('en_US' == $update->locale && 'en_US' == get_locale() ) ?
                        $update->current : sprintf("%s&ndash;<strong>%s</strong>", $update->current, $update->locale);
        $current = false;
        if ( !isset($update->response) || 'latest' == $update->response )
                        $update->current : sprintf("%s&ndash;<strong>%s</strong>", $update->current, $update->locale);
        $current = false;
        if ( !isset($update->response) || 'latest' == $update->response )
@@ -53,6 +53,9 @@ function list_core_update( $update ) {
        echo '</p>';
        if ( 'en_US' != $update->locale && ( !isset($wp_local_package) || $wp_local_package != $update->locale ) )
            echo '<p class="hint">'.__('This localized version contains both the translation and various other localization fixes. You can skip upgrading if you want to keep your current translation.').'</p>';
        echo '</p>';
        if ( 'en_US' != $update->locale && ( !isset($wp_local_package) || $wp_local_package != $update->locale ) )
            echo '<p class="hint">'.__('This localized version contains both the translation and various other localization fixes. You can skip upgrading if you want to keep your current translation.').'</p>';
+       else if ( 'en_US' == $update->locale && get_locale() != 'en_US' ) {
+           echo '<p class="hint">'.sprintf( __('You are about to install WordPress %s <strong>in English.</strong> There is a chance this upgrade will break your translation. You may prefer to wait for the localized version to be released.'), $update->current ).'</p>';
+       }
        echo '</form>';
 
 }
        echo '</form>';
 
 }