WordPress 3.4
[autoinstalls/wordpress.git] / wp-admin / admin.php
index 46e45e34d837f89d2896c41fa0a056bd301ee48a..015ced3013a14a49aecc0fd2fb8d9ff21c2a1190 100644 (file)
  * @since 2.3.2
  */
 if ( ! defined('WP_ADMIN') )
-       define('WP_ADMIN', TRUE);
+       define('WP_ADMIN', true);
 
 if ( ! defined('WP_NETWORK_ADMIN') )
-       define('WP_NETWORK_ADMIN', FALSE);
+       define('WP_NETWORK_ADMIN', false);
 
 if ( ! defined('WP_USER_ADMIN') )
-       define('WP_USER_ADMIN', FALSE);
+       define('WP_USER_ADMIN', false);
 
 if ( ! WP_NETWORK_ADMIN && ! WP_USER_ADMIN ) {
-       define('WP_BLOG_ADMIN', TRUE);
+       define('WP_BLOG_ADMIN', true);
 }
 
 if ( isset($_GET['import']) && !defined('WP_LOAD_IMPORTERS') )
@@ -30,7 +30,7 @@ if ( isset($_GET['import']) && !defined('WP_LOAD_IMPORTERS') )
 require_once(dirname(dirname(__FILE__)) . '/wp-load.php');
 
 if ( get_option('db_upgraded') ) {
-       $wp_rewrite->flush_rules();
+       flush_rewrite_rules();
        update_option( 'db_upgraded',  false );
 
        /**
@@ -153,7 +153,6 @@ if ( isset($plugin_page) ) {
                if ( validate_file($plugin_page) )
                        wp_die(__('Invalid plugin page'));
 
-
                if ( !( file_exists(WP_PLUGIN_DIR . "/$plugin_page") && is_file(WP_PLUGIN_DIR . "/$plugin_page") ) && !( file_exists(WPMU_PLUGIN_DIR . "/$plugin_page") && is_file(WPMU_PLUGIN_DIR . "/$plugin_page") ) )
                        wp_die(sprintf(__('Cannot load %s.'), htmlentities($plugin_page)));
 
@@ -229,5 +228,3 @@ if ( isset($plugin_page) ) {
 
 if ( !empty($_REQUEST['action']) )
        do_action('admin_action_' . $_REQUEST['action']);
-
-?>