WordPress 4.2.1
[autoinstalls/wordpress.git] / wp-admin / upgrade.php
index 57dedad94cc69f4f9c5ef13751b5469af6d1a50a..249de5a2398d620ce65d7591a05bbb5c4e45c564 100644 (file)
@@ -35,6 +35,8 @@ if ( 'upgrade_db' === $step ) {
        die( '0' );
 }
 
+global $wp_version, $required_php_version, $required_mysql_version;
+
 $step = (int) $step;
 
 $php_version    = phpversion();
@@ -69,18 +71,20 @@ else
 
 <?php elseif ( !$php_compat || !$mysql_compat ) :
        if ( !$mysql_compat && !$php_compat )
-               printf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $wp_version, $required_php_version, $required_mysql_version, $php_version, $mysql_version );
+               printf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $wp_version, $required_php_version, $required_mysql_version, $php_version, $mysql_version );
        elseif ( !$php_compat )
-               printf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $wp_version, $required_php_version, $php_version );
+               printf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $wp_version, $required_php_version, $php_version );
        elseif ( !$mysql_compat )
-               printf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires MySQL version %2$s or higher. You are running version %3$s.'), $wp_version, $required_mysql_version, $mysql_version );
+               printf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires MySQL version %2$s or higher. You are running version %3$s.'), $wp_version, $required_mysql_version, $mysql_version );
 ?>
 <?php else :
 switch ( $step ) :
        case 0:
                $goback = wp_get_referer();
-               $goback = esc_url_raw( $goback );
-               $goback = urlencode( $goback );
+               if ( $goback ) {
+                       $goback = esc_url_raw( $goback );
+                       $goback = urlencode( $goback );
+               }
 ?>
 <h2><?php _e( 'Database Update Required' ); ?></h2>
 <p><?php _e( 'WordPress has been updated! Before we send you on your way, we have to update your database to the newest version.' ); ?></p>