WordPress 4.3-scripts
[autoinstalls/wordpress.git] / wp-admin / update-core.php
index 0c7d297b9e83cfeaeb1c827f168df3b0beede0fa..969021696560b410865d94a9b79364446ab99240 100644 (file)
@@ -22,6 +22,16 @@ if ( is_multisite() && ! is_network_admin() ) {
 if ( ! current_user_can( 'update_core' ) && ! current_user_can( 'update_themes' ) && ! current_user_can( 'update_plugins' ) )
        wp_die( __( 'You do not have sufficient permissions to update this site.' ) );
 
+/**
+ *
+ * @global string $wp_local_package
+ * @global wpdb   $wpdb
+ * @global string $wp_version
+ *
+ * @staticvar bool $first_pass
+ *
+ * @param object $update
+ */
 function list_core_update( $update ) {
        global $wp_local_package, $wpdb, $wp_version;
        static $first_pass = true;
@@ -58,13 +68,13 @@ function list_core_update( $update ) {
                                $mysql_compat = version_compare( $mysql_version, $update->mysql_version, '>=' );
 
                        if ( !$mysql_compat && !$php_compat )
-                               $message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
+                               $message = sprintf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
                        elseif ( !$php_compat )
-                               $message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
+                               $message = sprintf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
                        elseif ( !$mysql_compat )
-                               $message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires MySQL version %2$s or higher. You are running version %3$s.'), $update->current, $update->mysql_version, $mysql_version );
+                               $message = sprintf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires MySQL version %2$s or higher. You are running version %3$s.'), $update->current, $update->mysql_version, $mysql_version );
                        else
-                               $message =      sprintf(__('You can update to <a href="http://codex.wordpress.org/Version_%1$s">WordPress %2$s</a> automatically or download the package and install it manually:'), $update->current, $version_string);
+                               $message =      sprintf(__('You can update to <a href="https://codex.wordpress.org/Version_%1$s">WordPress %2$s</a> automatically or download the package and install it manually:'), $update->current, $version_string);
                        if ( !$mysql_compat || !$php_compat )
                                $show_buttons = false;
                }
@@ -104,6 +114,9 @@ function list_core_update( $update ) {
 
 }
 
+/**
+ * @since 2.7.0
+ */
 function dismissed_updates() {
        $dismissed = get_core_updates( array( 'dismissed' => true, 'available' => false ) );
        if ( $dismissed ) {
@@ -136,7 +149,9 @@ function dismissed_updates() {
  *
  * @since 2.7.0
  *
- * @return null
+ * @global string $wp_version
+ * @global string $required_php_version
+ * @global string $required_mysql_version
  */
 function core_upgrade_preamble() {
        global $wp_version, $required_php_version, $required_mysql_version;
@@ -162,8 +177,8 @@ function core_upgrade_preamble() {
                }
                echo '</h3>';
        } else {
-               echo '<div class="updated inline"><p>';
-               _e('<strong>Important:</strong> before updating, please <a href="http://codex.wordpress.org/WordPress_Backups">back up your database and files</a>. For help with updates, visit the <a href="http://codex.wordpress.org/Updating_WordPress">Updating WordPress</a> Codex page.');
+               echo '<div class="notice notice-warning"><p>';
+               _e('<strong>Important:</strong> before updating, please <a href="https://codex.wordpress.org/WordPress_Backups">back up your database and files</a>. For help with updates, visit the <a href="https://codex.wordpress.org/Updating_WordPress">Updating WordPress</a> Codex page.');
                echo '</p></div>';
 
                echo '<h3 class="response">';
@@ -198,6 +213,10 @@ function core_upgrade_preamble() {
        dismissed_updates();
 }
 
+/**
+ *
+ * @global string $wp_version
+ */
 function list_plugin_updates() {
        global $wp_version;
 
@@ -226,17 +245,11 @@ function list_plugin_updates() {
 <table class="widefat" id="update-plugins-table">
        <thead>
        <tr>
-               <th scope="col" class="manage-column check-column"><input type="checkbox" id="plugins-select-all" /></th>
+               <td scope="col" class="manage-column check-column"><input type="checkbox" id="plugins-select-all" /></td>
                <th scope="col" class="manage-column"><label for="plugins-select-all"><?php _e('Select All'); ?></label></th>
        </tr>
        </thead>
 
-       <tfoot>
-       <tr>
-               <th scope="col" class="manage-column check-column"><input type="checkbox" id="plugins-select-all-2" /></th>
-               <th scope="col" class="manage-column"><label for="plugins-select-all-2"><?php _e('Select All'); ?></label></th>
-       </tr>
-       </tfoot>
        <tbody class="plugins">
 <?php
        foreach ( (array) $plugins as $plugin_file => $plugin_data) {
@@ -282,12 +295,22 @@ function list_plugin_updates() {
        }
 ?>
        </tbody>
+
+       <tfoot>
+       <tr>
+               <td scope="col" class="manage-column check-column"><input type="checkbox" id="plugins-select-all-2" /></td>
+               <th scope="col" class="manage-column"><label for="plugins-select-all-2"><?php _e( 'Select All' ); ?></label></th>
+       </tr>
+       </tfoot>
 </table>
 <p><input id="upgrade-plugins-2" class="button" type="submit" value="<?php esc_attr_e('Update Plugins'); ?>" name="upgrade" /></p>
 </form>
 <?php
 }
 
+/**
+ * @since 2.9.0
+ */
 function list_theme_updates() {
        $themes = get_theme_updates();
        if ( empty( $themes ) ) {
@@ -297,28 +320,21 @@ function list_theme_updates() {
        }
 
        $form_action = 'update-core.php?action=do-theme-upgrade';
-
 ?>
 <h3><?php _e( 'Themes' ); ?></h3>
 <p><?php _e( 'The following themes have new versions available. Check the ones you want to update and then click &#8220;Update Themes&#8221;.' ); ?></p>
-<p><?php printf( __( '<strong>Please Note:</strong> Any customizations you have made to theme files will be lost. Please consider using <a href="%s">child themes</a> for modifications.' ), __( 'http://codex.wordpress.org/Child_Themes' ) ); ?></p>
+<p><?php printf( __( '<strong>Please Note:</strong> Any customizations you have made to theme files will be lost. Please consider using <a href="%s">child themes</a> for modifications.' ), __( 'https://codex.wordpress.org/Child_Themes' ) ); ?></p>
 <form method="post" action="<?php echo esc_url( $form_action ); ?>" name="upgrade-themes" class="upgrade">
 <?php wp_nonce_field('upgrade-core'); ?>
 <p><input id="upgrade-themes" class="button" type="submit" value="<?php esc_attr_e('Update Themes'); ?>" name="upgrade" /></p>
 <table class="widefat" id="update-themes-table">
        <thead>
        <tr>
-               <th scope="col" class="manage-column check-column"><input type="checkbox" id="themes-select-all" /></th>
+               <td scope="col" class="manage-column check-column"><input type="checkbox" id="themes-select-all" /></td>
                <th scope="col" class="manage-column"><label for="themes-select-all"><?php _e('Select All'); ?></label></th>
        </tr>
        </thead>
 
-       <tfoot>
-       <tr>
-               <th scope="col" class="manage-column check-column"><input type="checkbox" id="themes-select-all-2" /></th>
-               <th scope="col" class="manage-column"><label for="themes-select-all-2"><?php _e('Select All'); ?></label></th>
-       </tr>
-       </tfoot>
        <tbody class="plugins">
 <?php
        foreach ( $themes as $stylesheet => $theme ) {
@@ -330,12 +346,22 @@ function list_theme_updates() {
        }
 ?>
        </tbody>
+
+       <tfoot>
+       <tr>
+               <td scope="col" class="manage-column check-column"><input type="checkbox" id="themes-select-all-2" /></td>
+               <th scope="col" class="manage-column"><label for="themes-select-all-2"><?php _e( 'Select All' ); ?></label></th>
+       </tr>
+       </tfoot>
 </table>
 <p><input id="upgrade-themes-2" class="button" type="submit" value="<?php esc_attr_e('Update Themes'); ?>" name="upgrade" /></p>
 </form>
 <?php
 }
 
+/**
+ * @since 3.7.0
+ */
 function list_translation_updates() {
        $updates = wp_get_translation_updates();
        if ( ! $updates ) {
@@ -350,7 +376,7 @@ function list_translation_updates() {
        ?>
        <h3><?php _e( 'Translations' ); ?></h3>
        <form method="post" action="<?php echo esc_url( $form_action ); ?>" name="upgrade-translations" class="upgrade">
-               <p><?php _e( 'Some of your translations are out of date.' ); ?></p>
+               <p><?php _e( 'New translations are available.' ); ?></p>
                <?php wp_nonce_field( 'upgrade-translations' ); ?>
                <p><input class="button" type="submit" value="<?php esc_attr_e( 'Update Translations' ); ?>" name="upgrade" /></p>
        </form>
@@ -362,7 +388,9 @@ function list_translation_updates() {
  *
  * @since 2.7.0
  *
- * @return null
+ * @global WP_Filesystem_Base $wp_filesystem Subclass
+ *
+ * @param bool $reinstall
  */
 function do_core_upgrade( $reinstall = false ) {
        global $wp_filesystem;
@@ -387,17 +415,17 @@ function do_core_upgrade( $reinstall = false ) {
 
 ?>
        <div class="wrap">
-       <h2><?php _e('Update WordPress'); ?></h2>
+       <h1><?php _e( 'Update WordPress' ); ?></h1>
 <?php
 
-       if ( false === ( $credentials = request_filesystem_credentials( $url, '', false, ABSPATH, array(), $allow_relaxed_file_ownership ) ) ) {
+       if ( false === ( $credentials = request_filesystem_credentials( $url, '', false, ABSPATH, array( 'version', 'locale' ), $allow_relaxed_file_ownership ) ) ) {
                echo '</div>';
                return;
        }
 
        if ( ! WP_Filesystem( $credentials, ABSPATH, $allow_relaxed_file_ownership ) ) {
                // Failed to connect, Error and request again
-               request_filesystem_credentials( $url, '', true, ABSPATH, array(), $allow_relaxed_file_ownership );
+               request_filesystem_credentials( $url, '', true, ABSPATH, array( 'version', 'locale' ), $allow_relaxed_file_ownership );
                echo '</div>';
                return;
        }
@@ -438,6 +466,9 @@ function do_core_upgrade( $reinstall = false ) {
        <?php
 }
 
+/**
+ * @since 2.7.0
+ */
 function do_dismiss_core_update() {
        $version = isset( $_POST['version'] )? $_POST['version'] : false;
        $locale = isset( $_POST['locale'] )? $_POST['locale'] : 'en_US';
@@ -449,6 +480,9 @@ function do_dismiss_core_update() {
        exit;
 }
 
+/**
+ * @since 2.7.0
+ */
 function do_undismiss_core_update() {
        $version = isset( $_POST['version'] )? $_POST['version'] : false;
        $locale = isset( $_POST['locale'] )? $_POST['locale'] : 'en_US';
@@ -496,7 +530,7 @@ get_current_screen()->add_help_tab( array(
 
 get_current_screen()->set_help_sidebar(
        '<p><strong>' . __('For more information:') . '</strong></p>' .
-       '<p>' . __( '<a href="http://codex.wordpress.org/Dashboard_Updates_Screen" target="_blank">Documentation on Updating WordPress</a>' ) . '</p>' .
+       '<p>' . __( '<a href="https://codex.wordpress.org/Dashboard_Updates_Screen" target="_blank">Documentation on Updating WordPress</a>' ) . '</p>' .
        '<p>' . __( '<a href="https://wordpress.org/support/" target="_blank">Support Forums</a>' ) . '</p>'
 );
 
@@ -508,7 +542,7 @@ if ( 'upgrade-core' == $action ) {
        require_once(ABSPATH . 'wp-admin/admin-header.php');
        ?>
        <div class="wrap">
-       <h2><?php _e('WordPress Updates'); ?></h2>
+       <h1><?php _e( 'WordPress Updates' ); ?></h1>
        <?php
        if ( $upgrade_error ) {
                echo '<div class="error"><p>';
@@ -590,7 +624,7 @@ if ( 'upgrade-core' == $action ) {
 
        require_once(ABSPATH . 'wp-admin/admin-header.php');
        echo '<div class="wrap">';
-       echo '<h2>' . esc_html__('Update Plugins') . '</h2>';
+       echo '<h1>' . __( 'Update Plugins' ) . '</h1>';
        echo '<iframe src="', $url, '" style="width: 100%; height: 100%; min-height: 750px;" frameborder="0"></iframe>';
        echo '</div>';
        include(ABSPATH . 'wp-admin/admin-footer.php');
@@ -619,7 +653,7 @@ if ( 'upgrade-core' == $action ) {
        require_once(ABSPATH . 'wp-admin/admin-header.php');
        ?>
        <div class="wrap">
-               <h2><?php echo esc_html__('Update Themes') ?></h2>
+               <h1><?php _e( 'Update Themes' ); ?></h1>
                <iframe src="<?php echo $url ?>" style="width: 100%; height: 100%; min-height: 750px;" frameborder="0"></iframe>
        </div>
        <?php