]> scripts.mit.edu Git - autoinstalls/wordpress.git/blobdiff - wp-admin/network/upgrade.php
WordPress 4.6.3
[autoinstalls/wordpress.git] / wp-admin / network / upgrade.php
index f1574aeabba856abd8433ee650557c759bcddf10..199838cf57233b44c367ffd181aeae2e27cab23e 100644 (file)
@@ -36,10 +36,10 @@ get_current_screen()->set_help_sidebar(
 require_once( ABSPATH . 'wp-admin/admin-header.php' );
 
 if ( ! current_user_can( 'manage_network' ) )
-       wp_die( __( 'You do not have permission to access this page.' ), 403 );
+       wp_die( __( 'Sorry, you are not allowed to access this page.' ), 403 );
 
 echo '<div class="wrap">';
-echo '<h2>' . __( 'Upgrade Network' ) . '</h2>';
+echo '<h1>' . __( 'Upgrade Network' ) . '</h1>';
 
 $action = isset($_GET['action']) ? $_GET['action'] : 'show';
 
@@ -48,6 +48,9 @@ switch ( $action ) {
                $n = ( isset($_GET['n']) ) ? intval($_GET['n']) : 0;
 
                if ( $n < 5 ) {
+                       /**
+                        * @global string $wp_db_version
+                        */
                        global $wp_db_version;
                        update_site_option( 'wpmu_upgrade_site', $wp_db_version );
                }
@@ -66,7 +69,11 @@ switch ( $action ) {
 
                        echo "<li>$siteurl</li>";
 
-                       $response = wp_remote_get( $upgrade_url, array( 'timeout' => 120, 'httpversion' => '1.1' ) );
+                       $response = wp_remote_get( $upgrade_url, array(
+                               'timeout'     => 120,
+                               'httpversion' => '1.1',
+                               'sslverify'   => false,
+                       ) );
                        if ( is_wp_error( $response ) ) {
                                wp_die( sprintf(
                                        /* translators: 1: site url, 2: server error message */
@@ -89,7 +96,7 @@ switch ( $action ) {
                         *
                         * @since MU
                         *
-                        * @param int $blog_id The id of the blog.
+                        * @param int $blog_id The Site ID.
                         */
                        do_action( 'wpmu_upgrade_site', $details[ 'blog_id' ] );
                }
@@ -108,12 +115,12 @@ switch ( $action ) {
        default:
                if ( get_site_option( 'wpmu_upgrade_site' ) != $GLOBALS['wp_db_version'] ) :
                ?>
-               <h3><?php _e( 'Database Upgrade Required' ); ?></h3>
+               <h2><?php _e( 'Database Update Required' ); ?></h2>
                <p><?php _e( 'WordPress has been updated! Before we send you on your way, we need to individually upgrade the sites in your network.' ); ?></p>
                <?php endif; ?>
 
-               <p><?php _e( 'The database upgrade process may take a little while, so please be patient.' ); ?></p>
-               <p><a class="button" href="upgrade.php?action=upgrade"><?php _e( 'Upgrade Network' ); ?></a></p>
+               <p><?php _e( 'The database update process may take a little while, so please be patient.' ); ?></p>
+               <p><a class="button button-primary" href="upgrade.php?action=upgrade"><?php _e( 'Upgrade Network' ); ?></a></p>
                <?php
                /**
                 * Fires before the footer on the network upgrade screen.