]> scripts.mit.edu Git - autoinstalls/wordpress.git/blobdiff - wp-admin/import.php
Wordpress 2.9.2-scripts
[autoinstalls/wordpress.git] / wp-admin / import.php
index 6a12022c990075d5895c38b24967c505313a8ecf..86dcb1479aa4d1f6c5a5461b1ad0110425d99032 100644 (file)
@@ -1,12 +1,25 @@
 <?php
+/**
+ * Import WordPress Administration Panel
+ *
+ * @package WordPress
+ * @subpackage Administration
+ */
+
+/** Load WordPress Bootstrap */
 require_once ('admin.php');
+
+if ( !current_user_can('edit_files') )
+       wp_die(__('You do not have sufficient permissions to import content in this blog.'));
+
 $title = __('Import');
-$parent_file = 'edit.php';
 require_once ('admin-header.php');
+$parent_file = 'tools.php';
 ?>
 
 <div class="wrap">
-<h2><?php _e('Import'); ?></h2>
+<?php screen_icon(); ?>
+<h2><?php echo esc_html( $title ); ?></h2>
 <p><?php _e('If you have posts or comments in another system, WordPress can import those into this blog. To get started, choose a system to import from below:'); ?></p>
 
 <?php
@@ -32,7 +45,7 @@ if (empty ($importers)) {
        echo '<p>'.__('No importers are available.').'</p>'; // TODO: make more helpful
 } else {
 ?>
-<table class="widefat">
+<table class="widefat" cellspacing="0">
 
 <?php
        $style = '';
@@ -44,7 +57,7 @@ if (empty ($importers)) {
                        $style = 'class="'.$style.'"';
                echo "
                        <tr $style>
-                               <td class='import-system'>$action</td>
+                               <td class='import-system row-title'>$action</td>
                                <td class='desc'>{$data[1]}</td>
                        </tr>";
        }