Wordpress 2.8.5-scripts
[autoinstalls/wordpress.git] / wp-admin / update.php
index 803f50e27d3d0b71f2c9f2461123b7bf58125576..f05de5dffa0b4091722a0bc19b913f590992ac76 100644 (file)
@@ -1,6 +1,6 @@
 <?php
 /**
- * Update Plugin/Theme administration panel.
+ * Update/Install Plugin/Theme administration panel.
  *
  * @package WordPress
  * @subpackage Administration
 /** WordPress Administration Bootstrap */
 require_once('admin.php');
 
-if ( ! current_user_can('update_plugins') )
-       wp_die(__('You do not have sufficient permissions to update plugins for this blog.'));
-
-/**
- * Plugin upgrade display.
- *
- * @since 2.5
- *
- * @param string $plugin Plugin
- */
-function do_plugin_upgrade($plugin) {
-       global $wp_filesystem;
-
-       $url = wp_nonce_url("update.php?action=upgrade-plugin&plugin=$plugin", "upgrade-plugin_$plugin");
-       if ( false === ($credentials = request_filesystem_credentials($url)) )
-               return;
-
-       if ( ! WP_Filesystem($credentials) ) {
-               $error = true;
-               if ( is_object($wp_filesystem) && $wp_filesystem->errors->get_error_code() )
-                       $error = $wp_filesystem->errors;
-               request_filesystem_credentials($url, '', $error); //Failed to connect, Error and request again
-               return;
-       }
-
-       echo '<div class="wrap">';
-       echo '<h2>' . __('Upgrade Plugin') . '</h2>';
-       if ( $wp_filesystem->errors->get_error_code() ) {
-               foreach ( $wp_filesystem->errors->get_error_messages() as $message )
-                       show_message($message);
-               echo '</div>';
-               return;
-       }
-
-       $was_activated = is_plugin_active($plugin); //Check now, It'll be deactivated by the next line if it is
-
-       $result = wp_update_plugin($plugin, 'show_message');
-
-       if ( is_wp_error($result) ) {
-               show_message($result);
-               show_message( __('Plugin upgrade Failed') );
-       } else {
-               $plugin_file = $result;
-               show_message( __('Plugin upgraded successfully') );
-               if( $result && $was_activated ){
-                       show_message(__('Attempting reactivation of the plugin'));
-                       echo '<iframe style="border:0;overflow:hidden" width="100%" height="170px" src="' . wp_nonce_url('update.php?action=activate-plugin&plugin=' . $plugin_file, 'activate-plugin_' . $plugin_file) .'"></iframe>';
-               }
-               $update_actions =  array(
-                       'activate_plugin' => '<a href="' . wp_nonce_url('plugins.php?action=activate&amp;plugin=' . $plugin_file, 'activate-plugin_' . $plugin_file) . '" title="' . attribute_escape(__('Activate this plugin')) . '" target="_parent">' . __('Activate Plugin') . '</a>',
-                       'plugins_page' => '<a href="' . admin_url('plugins.php') . '" title="' . attribute_escape(__('Goto plugins page')) . '" target="_parent">' . __('Return to Plugins page') . '</a>'
-               );
-               if ( $was_activated )
-                       unset( $update_actions['activate_plugin'] );
-
-               $update_actions = apply_filters('update_plugin_complete_actions', $update_actions, $plugin_file);
-               if ( ! empty($update_actions) )
-                       show_message('<strong>' . __('Actions:') . '</strong> ' . implode(' | ', (array)$update_actions));
-       }
-       echo '</div>';
-}
-
-/**
- * Theme upgrade display.
- *
- * @since 2.5
- *
- * @param string $plugin Plugin
- */
-function do_theme_upgrade($theme) {
-       global $wp_filesystem;
-
-       $url = wp_nonce_url('update.php?action=upgrade-theme&theme=' . urlencode($theme), 'upgrade-plugin_' . urlencode($theme));
-       if ( false === ($credentials = request_filesystem_credentials($url)) )
-               return;
-
-       if ( ! WP_Filesystem($credentials) ) {
-               $error = true;
-               if ( is_object($wp_filesystem) && $wp_filesystem->errors->get_error_code() )
-                       $error = $wp_filesystem->errors;
-               request_filesystem_credentials($url, '', $error); //Failed to connect, Error and request again
-               return;
-       }
-
-       echo '<div class="wrap">';
-       echo '<h2>' . __('Upgrade Theme') . '</h2>';
-       if ( $wp_filesystem->errors->get_error_code() ) {
-               foreach ( $wp_filesystem->errors->get_error_messages() as $message )
-                       show_message($message);
-               echo '</div>';
-               return;
-       }
-
-       //TODO: Is theme currently active?
-       $was_current = false; //is_plugin_active($plugin); //Check now, It'll be deactivated by the next line if it is
-
-       $result = wp_update_theme($theme, 'show_message');
-
-       if ( is_wp_error($result) ) {
-               show_message($result);
-               show_message( __('Installation Failed') );
-       } else {
-               //Result is the new plugin file relative to WP_PLUGIN_DIR
-               show_message( __('Theme upgraded successfully') );
-               if( $result && $was_current ){
-                       show_message(__('Setting theme as Current'));
-                       //TODO: Actually set it as active again.
-                       //echo '<iframe style="border:0" width="100%" height="170px" src="' . wp_nonce_url('update.php?action=activate-plugin&plugin=' . $result, 'activate-plugin_' . $result) .'"></iframe>';
-               }
-       }
-       echo '</div>';
-}
+include_once ABSPATH . 'wp-admin/includes/class-wp-upgrader.php';
 
 if ( isset($_GET['action']) ) {
-       $plugin = isset($_GET['plugin']) ? trim($_GET['plugin']) : '';
+       $plugin = isset($_REQUEST['plugin']) ? trim($_REQUEST['plugin']) : '';
        $theme = isset($_REQUEST['theme']) ? urldecode($_REQUEST['theme']) : '';
-       $action = isset($_GET['action']) ? $_GET['action'] : '';
+       $action = isset($_REQUEST['action']) ? $_REQUEST['action'] : '';
 
        if ( 'upgrade-plugin' == $action ) {
+               if ( ! current_user_can('update_plugins') )
+                       wp_die(__('You do not have sufficient permissions to update plugins for this blog.'));
+
                check_admin_referer('upgrade-plugin_' . $plugin);
+
                $title = __('Upgrade Plugin');
                $parent_file = 'plugins.php';
+               $submenu_file = 'plugins.php';
                require_once('admin-header.php');
-               do_plugin_upgrade($plugin);
+
+               $nonce = 'upgrade-plugin_' . $plugin;
+               $url = 'update.php?action=upgrade-plugin&plugin=' . $plugin;
+
+               $upgrader = new Plugin_Upgrader( new Plugin_Upgrader_Skin( compact('title', 'nonce', 'url', 'plugin') ) );
+               $upgrader->upgrade($plugin);
+
                include('admin-footer.php');
+
        } elseif ('activate-plugin' == $action ) {
+               if ( ! current_user_can('update_plugins') )
+                       wp_die(__('You do not have sufficient permissions to update plugins for this blog.'));
+
                check_admin_referer('activate-plugin_' . $plugin);
                if( ! isset($_GET['failure']) && ! isset($_GET['success']) ) {
                        wp_redirect( 'update.php?action=activate-plugin&failure=true&plugin=' . $plugin . '&_wpnonce=' . $_GET['_wpnonce'] );
@@ -153,14 +57,137 @@ if ( isset($_GET['action']) ) {
                        include(WP_PLUGIN_DIR . '/' . $plugin);
                }
                iframe_footer();
+       } elseif ( 'install-plugin' == $action ) {
+
+               if ( ! current_user_can('install_plugins') )
+                       wp_die(__('You do not have sufficient permissions to install plugins for this blog.'));
+
+               include_once ABSPATH . 'wp-admin/includes/plugin-install.php'; //for plugins_api..
+
+               check_admin_referer('install-plugin_' . $plugin);
+               $api = plugins_api('plugin_information', array('slug' => $plugin, 'fields' => array('sections' => false) ) ); //Save on a bit of bandwidth.
+
+               if ( is_wp_error($api) )
+                       wp_die($api);
+
+               $title = __('Plugin Install');
+               $parent_file = 'plugins.php';
+               $submenu_file = 'plugin-install.php';
+               require_once('admin-header.php');
+
+               $title = sprintf( __('Installing Plugin: %s'), $api->name . ' ' . $api->version );
+               $nonce = 'install-plugin_' . $plugin;
+               $url = 'update.php?action=install-plugin&plugin=' . $plugin;
+               $type = 'web'; //Install plugin type, From Web or an Upload.
+
+               $upgrader = new Plugin_Upgrader( new Plugin_Installer_Skin( compact('title', 'url', 'nonce', 'plugin', 'api') ) );
+               $upgrader->install($api->download_link);
+
+               include('admin-footer.php');
+
+       } elseif ( 'upload-plugin' == $action ) {
+
+               if ( ! current_user_can('install_plugins') )
+                       wp_die(__('You do not have sufficient permissions to install plugins for this blog.'));
+
+               check_admin_referer('plugin-upload');
+
+               $file_upload = new File_Upload_Upgrader('pluginzip', 'package');
+
+               $title = __('Upload Plugin');
+               $parent_file = 'plugins.php';
+               $submenu_file = 'plugin-install.php';
+               require_once('admin-header.php');
+
+               $title = sprintf( __('Installing Plugin from uploaded file: %s'), basename( $file_upload->filename ) );
+               $nonce = 'plugin-upload';
+               $url = add_query_arg(array('package' => $file_upload->filename ), 'update.php?action=upload-plugin');
+               $type = 'upload'; //Install plugin type, From Web or an Upload.
+
+               $upgrader = new Plugin_Upgrader( new Plugin_Installer_Skin( compact('type', 'title', 'nonce', 'url') ) );
+               $upgrader->install( $file_upload->package );
+
+               include('admin-footer.php');
+
        } elseif ( 'upgrade-theme' == $action ) {
+
+               if ( ! current_user_can('update_themes') )
+                       wp_die(__('You do not have sufficient permissions to update themes for this blog.'));
+
                check_admin_referer('upgrade-theme_' . $theme);
+
+               add_thickbox();
+               wp_enqueue_script('theme-preview');
                $title = __('Upgrade Theme');
                $parent_file = 'themes.php';
+               $submenu_file = 'themes.php';
                require_once('admin-header.php');
-               do_theme_upgrade($theme);
+
+               $nonce = 'upgrade-theme_' . $theme;
+               $url = 'update.php?action=upgrade-theme&theme=' . $theme;
+
+               $upgrader = new Theme_Upgrader( new Theme_Upgrader_Skin( compact('title', 'nonce', 'url', 'theme') ) );
+               $upgrader->upgrade($theme);
+
                include('admin-footer.php');
-       }
-}
 
-?>
+       } elseif ( 'install-theme' == $action ) {
+
+               if ( ! current_user_can('install_themes') )
+                       wp_die(__('You do not have sufficient permissions to install themes for this blog.'));
+
+               include_once ABSPATH . 'wp-admin/includes/theme-install.php'; //for themes_api..
+
+               check_admin_referer('install-theme_' . $theme);
+               $api = themes_api('theme_information', array('slug' => $theme, 'fields' => array('sections' => false) ) ); //Save on a bit of bandwidth.
+
+               if ( is_wp_error($api) )
+                       wp_die($api);
+
+               add_thickbox();
+               wp_enqueue_script('theme-preview');
+               $title = __('Install Themes');
+               $parent_file = 'themes.php';
+               $submenu_file = 'theme-install.php';
+               require_once('admin-header.php');
+
+               $title = sprintf( __('Installing theme: %s'), $api->name . ' ' . $api->version );
+               $nonce = 'install-theme_' . $theme;
+               $url = 'update.php?action=install-theme&theme=' . $theme;
+               $type = 'web'; //Install theme type, From Web or an Upload.
+
+               $upgrader = new Theme_Upgrader( new Theme_Installer_Skin( compact('title', 'url', 'nonce', 'plugin', 'api') ) );
+               $upgrader->install($api->download_link);
+
+               include('admin-footer.php');
+
+       } elseif ( 'upload-theme' == $action ) {
+
+               if ( ! current_user_can('install_themes') )
+                       wp_die(__('You do not have sufficient permissions to install themes for this blog.'));
+
+               check_admin_referer('theme-upload');
+
+               $file_upload = new File_Upload_Upgrader('themezip', 'package');
+
+               $title = __('Upload Theme');
+               $parent_file = 'themes.php';
+               $submenu_file = 'theme-install.php';
+               add_thickbox();
+               wp_enqueue_script('theme-preview');
+               require_once('admin-header.php');
+
+               $title = sprintf( __('Installing Theme from uploaded file: %s'), basename( $file_upload->filename ) );
+               $nonce = 'theme-upload';
+               $url = add_query_arg(array('package' => $file_upload->filename), 'update.php?action=upload-theme');
+               $type = 'upload'; //Install plugin type, From Web or an Upload.
+
+               $upgrader = new Theme_Upgrader( new Theme_Installer_Skin( compact('type', 'title', 'nonce', 'url') ) );
+               $upgrader->install( $file_upload->package );
+
+               include('admin-footer.php');
+
+       } else {
+               do_action('update-custom_' . $action);
+       }
+}
\ No newline at end of file