WordPress 3.4.2
[autoinstalls/wordpress.git] / wp-admin / includes / update-core.php
index 2e383ddfcbce9471e6f6d7c0a57151c43469f3ab..392bb571d830c07cddb9aafb6b0b43b0f2f2ad62 100644 (file)
@@ -477,7 +477,7 @@ function update_core($from, $to) {
        $mysql_version  = $wpdb->db_version();
        $required_php_version = '5.2.4';
        $required_mysql_version = '5.0';
-       $wp_version = '3.4.1';
+       $wp_version = '3.4.2';
        $php_compat     = version_compare( $php_version, $required_php_version, '>=' );
        if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
                $mysql_compat = true;
@@ -680,7 +680,7 @@ function _copy_dir($from, $to, $skip_list = array() ) {
 function _redirect_to_about_wordpress( $new_version ) {
        global $wp_version, $pagenow, $action;
 
-       if ( version_compare( $wp_version, '3.4-RC1', '>=' ) )
+       if ( version_compare( $wp_version, '3.5-alpha', '>=' ) )
                return;
 
        // Ensure we only run this on the update-core.php page. wp_update_core() could be called in other contexts.
@@ -695,12 +695,17 @@ function _redirect_to_about_wordpress( $new_version ) {
 
        // See do_core_upgrade()
        show_message( __('WordPress updated successfully') );
-       show_message( '<span class="hide-if-no-js">' . sprintf( __( 'Welcome to WordPress %1$s. You will be redirected to the About WordPress screen. If not, click <a href="%s">here</a>.' ), $new_version, esc_url( self_admin_url( 'about.php?updated' ) ) ) . '</span>' );
-       show_message( '<span class="hide-if-js">' . sprintf( __( 'Welcome to WordPress %1$s. <a href="%2$s">Learn more</a>.' ), $new_version, esc_url( self_admin_url( 'about.php?updated' ) ) ) . '</span>' );
+
+       $js_message = __( 'Welcome to WordPress %1$s. You will be redirected to the About WordPress screen. If not, click <a href="%s">here</a>.' );
+       $js_message = str_replace( '"%s"', '"%2$s"', $js_message ); // in lieu of breaking the string.
+
+       // self_admin_url() won't exist when upgrading from <= 3.0, so relative URLs are intentional.
+       show_message( '<span class="hide-if-no-js">' . sprintf( $js_message, $new_version, 'about.php?updated' ) . '</span>' );
+       show_message( '<span class="hide-if-js">' . sprintf( __( 'Welcome to WordPress %1$s. <a href="%2$s">Learn more</a>.' ), $new_version, 'about.php?updated' ) . '</span>' );
        echo '</div>';
        ?>
 <script type="text/javascript">
-window.location = '<?php echo self_admin_url( 'about.php?updated' ); ?>';
+window.location = 'about.php?updated';
 </script>
        <?php