Wordpress 2.9.1
[autoinstalls/wordpress.git] / wp-admin / update-core.php
index ed24f180fd51c272c2bc850e2e8f56b5f7ff9be4..69a9e5c0696238070435478008af87b4f064ced0 100644 (file)
@@ -153,13 +153,13 @@ function list_plugin_updates() {
        $form_action = 'update-core.php?action=do-plugin-upgrade';
 
        $core_updates = get_core_updates();
-       if ( !isset($core_updates[0]->response) || 'latest' == $core_updates[0]->response || 'development' == $core_updates[0]->response )
+       if ( !isset($core_updates[0]->response) || 'latest' == $core_updates[0]->response || 'development' == $core_updates[0]->response || version_compare( $core_updates[0]->current, $cur_wp_version, '=') )
                $core_update_version = false;
        else
                $core_update_version = $core_updates[0]->current;
        ?>
 <h3><?php _e('Plugins'); ?></h3>
-<p><?php _e('The following plugins have new versions available.  Check the ones you want to upgrade and then click "Upgrade Plugins".'); ?><p>
+<p><?php _e('The following plugins have new versions available.  Check the ones you want to upgrade and then click "Upgrade Plugins".'); ?></p>
 <form method="post" action="<?php echo $form_action; ?>" name="upgrade-plugins" class="upgrade">
 <?php wp_nonce_field('upgrade-core'); ?>
 <p><input id="upgrade-plugins" class="button" type="submit" value="<?php esc_attr_e('Upgrade Plugins'); ?>" name="upgrade" /></p>