Wordpress 3.3.1-scripts
[autoinstalls/wordpress.git] / wp-admin / setup-config.php
index abab9904de2639f6773fb320ab6eba01ea2a3f4d..efc158fc8978acd30bb4166156ccff347bd12340 100644 (file)
@@ -5,6 +5,8 @@
  * The permissions for the base directory must allow for writing files in order
  * for the wp-config.php to be created using this page.
  *
+ * @internal This file must be parsable by PHP4.
+ *
  * @package WordPress
  * @subpackage Administration
  */
  */
 define('WP_INSTALLING', true);
 
+/**
+ * We are blissfully unaware of anything.
+ */
+define('WP_SETUP_CONFIG', true);
+
 /**
  * Disable error reporting
  *
- * Set this to error_reporting( E_ALL ) or error_reporting( E_ALL | E_STRICT ) f
-or debugging
+ * Set this to error_reporting( E_ALL ) or error_reporting( E_ALL | E_STRICT ) for debugging
  */
 error_reporting(0);
 
@@ -32,11 +38,16 @@ error_reporting(0);
 define('ABSPATH', dirname(dirname(__FILE__)).'/');
 define('WPINC', 'wp-includes');
 define('WP_CONTENT_DIR', ABSPATH . 'wp-content');
+define('WP_DEBUG', false);
 /**#@-*/
 
+require_once(ABSPATH . WPINC . '/load.php');
+require_once(ABSPATH . WPINC . '/version.php');
+wp_check_php_mysql_versions();
+
 require_once(ABSPATH . WPINC . '/compat.php');
 require_once(ABSPATH . WPINC . '/functions.php');
-require_once(ABSPATH . WPINC . '/classes.php');
+require_once(ABSPATH . WPINC . '/class-wp-error.php');
 
 if (!file_exists(ABSPATH . 'wp-config-sample.php'))
        wp_die('Sorry, I need a wp-config-sample.php file to work from. Please re-upload this file from your WordPress installation.');
@@ -51,12 +62,6 @@ if (file_exists(ABSPATH . 'wp-config.php'))
 if (file_exists(ABSPATH . '../wp-config.php') && ! file_exists(ABSPATH . '../wp-settings.php'))
        wp_die("<p>The file 'wp-config.php' already exists one level above your WordPress installation. If you need to reset any of the configuration items in this file, please delete it first. You may try <a href='install.php'>installing now</a>.</p>");
 
-if ( version_compare( '4.3', phpversion(), '>' ) )
-       wp_die( sprintf( /*WP_I18N_OLD_PHP*/'Your server is running PHP version %s but WordPress requires at least 4.3.'/*/WP_I18N_OLD_PHP*/, phpversion() ) );
-
-if ( !extension_loaded('mysql') && !file_exists(ABSPATH . 'wp-content/db.php') )
-       wp_die( /*WP_I18N_OLD_MYSQL*/'Your PHP installation appears to be missing the MySQL extension which is required by WordPress.'/*/WP_I18N_OLD_MYSQL*/ );
-
 if (isset($_GET['step']))
        $step = $_GET['step'];
 else
@@ -73,7 +78,7 @@ else
 function display_header() {
        header( 'Content-Type: text/html; charset=utf-8' );
 ?>
-<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
+<!DOCTYPE html>
 <html xmlns="http://www.w3.org/1999/xhtml">
 <head>
 <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
@@ -102,7 +107,7 @@ switch($step) {
 <p><strong>If for any reason this automatic file creation doesn't work, don't worry. All this does is fill in the database information to a configuration file. You may also simply open <code>wp-config-sample.php</code> in a text editor, fill in your information, and save it as <code>wp-config.php</code>. </strong></p>
 <p>In all likelihood, these items were supplied to you by your Web Host. If you do not have this information, then you will need to contact them before you can continue. If you&#8217;re all ready&hellip;</p>
 
-<p class="step"><a href="setup-config.php?step=1" class="button">Let&#8217;s go!</a></p>
+<p class="step"><a href="setup-config.php?step=1<?php if ( isset( $_GET['noapi'] ) ) echo '&amp;noapi'; ?>" class="button">Let&#8217;s go!</a></p>
 <?php
        break;
 
@@ -125,19 +130,20 @@ switch($step) {
                <tr>
                        <th scope="row"><label for="pwd">Password</label></th>
                        <td><input name="pwd" id="pwd" type="text" size="25" value="password" /></td>
-                       <td>...and MySQL password.</td>
+                       <td>...and your MySQL password.</td>
                </tr>
                <tr>
                        <th scope="row"><label for="dbhost">Database Host</label></th>
                        <td><input name="dbhost" id="dbhost" type="text" size="25" value="localhost" /></td>
-                       <td>99% chance you won't need to change this value.</td>
+                       <td>You should be able to get this info from your web host, if <code>localhost</code> does not work.</td>
                </tr>
                <tr>
                        <th scope="row"><label for="prefix">Table Prefix</label></th>
-                       <td><input name="prefix" id="prefix" type="text" id="prefix" value="wp_" size="25" /></td>
+                       <td><input name="prefix" id="prefix" type="text" value="wp_" size="25" /></td>
                        <td>If you want to run multiple WordPress installations in a single database, change this.</td>
                </tr>
        </table>
+       <?php if ( isset( $_GET['noapi'] ) ) { ?><input name="noapi" type="hidden" value="true" /><?php } ?>
        <p class="step"><input name="submit" type="submit" value="Submit" class="button" /></p>
 </form>
 <?php
@@ -149,7 +155,12 @@ switch($step) {
        $passwrd = trim($_POST['pwd']);
        $dbhost  = trim($_POST['dbhost']);
        $prefix  = trim($_POST['prefix']);
-       if (empty($prefix)) $prefix = 'wp_';
+       if ( empty($prefix) )
+               $prefix = 'wp_';
+
+       // Validate $prefix: it can only contain letters, numbers and underscores
+       if ( preg_match( '|[^a-z0-9_]|i', $prefix ) )
+               wp_die( /*WP_I18N_BAD_PREFIX*/'<strong>ERROR</strong>: "Table Prefix" can only contain numbers, letters, and underscores.'/*/WP_I18N_BAD_PREFIX*/ );
 
        // Test the db connection.
        /**#@+
@@ -163,19 +174,54 @@ switch($step) {
 
        // We'll fail here if the values are no good.
        require_wp_db();
-       if ( !empty($wpdb->error) )
-               wp_die($wpdb->error->get_error_message());
+       if ( ! empty( $wpdb->error ) ) {
+               $back = '<p class="step"><a href="setup-config.php?step=1" onclick="javascript:history.go(-1);return false;" class="button">Try Again</a></p>';
+               wp_die( $wpdb->error->get_error_message() . $back );
+       }
+
+       // Fetch or generate keys and salts.
+       $no_api = isset( $_POST['noapi'] );
+       require_once( ABSPATH . WPINC . '/plugin.php' );
+       require_once( ABSPATH . WPINC . '/l10n.php' );
+       require_once( ABSPATH . WPINC . '/pomo/translations.php' );
+       if ( ! $no_api ) {
+               require_once( ABSPATH . WPINC . '/class-http.php' );
+               require_once( ABSPATH . WPINC . '/http.php' );
+               wp_fix_server_vars();
+               /**#@+
+                * @ignore
+                */
+               function get_bloginfo() {
+                       return ( ( is_ssl() ? 'https://' : 'http://' ) . $_SERVER['HTTP_HOST'] . str_replace( $_SERVER['PHP_SELF'], '/wp-admin/setup-config.php', '' ) );
+               }
+               /**#@-*/
+               $secret_keys = wp_remote_get( 'https://api.wordpress.org/secret-key/1.1/salt/' );
+       }
+
+       if ( $no_api || is_wp_error( $secret_keys ) ) {
+               $secret_keys = array();
+               require_once( ABSPATH . WPINC . '/pluggable.php' );
+               for ( $i = 0; $i < 8; $i++ ) {
+                       $secret_keys[] = wp_generate_password( 64, true, true );
+               }
+       } else {
+               $secret_keys = explode( "\n", wp_remote_retrieve_body( $secret_keys ) );
+               foreach ( $secret_keys as $k => $v ) {
+                       $secret_keys[$k] = substr( $v, 28, 64 );
+               }
+       }
+       $key = 0;
 
        foreach ($configFile as $line_num => $line) {
                switch (substr($line,0,16)) {
                        case "define('DB_NAME'":
-                               $configFile[$line_num] = str_replace("putyourdbnamehere", $dbname, $line);
+                               $configFile[$line_num] = str_replace("database_name_here", $dbname, $line);
                                break;
                        case "define('DB_USER'":
-                               $configFile[$line_num] = str_replace("'usernamehere'", "'$uname'", $line);
+                               $configFile[$line_num] = str_replace("'username_here'", "'$uname'", $line);
                                break;
                        case "define('DB_PASSW":
-                               $configFile[$line_num] = str_replace("'yourpasswordhere'", "'$passwrd'", $line);
+                               $configFile[$line_num] = str_replace("'password_here'", "'$passwrd'", $line);
                                break;
                        case "define('DB_HOST'":
                                $configFile[$line_num] = str_replace("localhost", $dbhost, $line);
@@ -183,6 +229,16 @@ switch($step) {
                        case '$table_prefix  =':
                                $configFile[$line_num] = str_replace('wp_', $prefix, $line);
                                break;
+                       case "define('AUTH_KEY":
+                       case "define('SECURE_A":
+                       case "define('LOGGED_I":
+                       case "define('NONCE_KE":
+                       case "define('AUTH_SAL":
+                       case "define('SECURE_A":
+                       case "define('LOGGED_I":
+                       case "define('NONCE_SA":
+                               $configFile[$line_num] = str_replace('put your unique phrase here', $secret_keys[$key++], $line );
+                               break;
                }
        }
        if ( ! is_writable(ABSPATH) ) :
@@ -190,9 +246,9 @@ switch($step) {
 ?>
 <p>Sorry, but I can't write the <code>wp-config.php</code> file.</p>
 <p>You can create the <code>wp-config.php</code> manually and paste the following text into it.</p>
-<textarea cols="90" rows="15"><?php
+<textarea cols="98" rows="15" class="code"><?php
                foreach( $configFile as $line ) {
-                       echo htmlentities($line);
+                       echo htmlentities($line, ENT_COMPAT, 'UTF-8');
                }
 ?></textarea>
 <p>After you've done that, click "Run the install."</p>