]> scripts.mit.edu Git - autoinstalls/wordpress.git/blobdiff - wp-admin/includes/update.php
WordPress 3.8.2
[autoinstalls/wordpress.git] / wp-admin / includes / update.php
index c90bd7aae615fd35038d6fa24be9d03ad477a568..c514d208e5f759950b588eb6f49bfe574367b3c7 100644 (file)
@@ -3,11 +3,9 @@
  * WordPress Administration Update API
  *
  * @package WordPress
- * @subpackage Admin
+ * @subpackage Administration
  */
 
-// The admin side of our 1.1 update system
-
 /**
  * Selects the first update version from the update_core option
  *
  */
 function get_preferred_from_update_core() {
        $updates = get_core_updates();
-       if ( !is_array( $updates ) )
+       if ( ! is_array( $updates ) )
                return false;
        if ( empty( $updates ) )
-               return (object)array('response' => 'latest');
+               return (object) array( 'response' => 'latest' );
        return $updates[0];
 }
 
@@ -26,55 +24,137 @@ function get_preferred_from_update_core() {
  * Get available core updates
  *
  * @param array $options Set $options['dismissed'] to true to show dismissed upgrades too,
- *     set $options['available'] to false to skip not-dimissed updates.
+ *     set $options['available'] to false to skip not-dismissed updates.
  * @return array Array of the update objects
  */
 function get_core_updates( $options = array() ) {
-       $options = array_merge( array('available' => true, 'dismissed' => false ), $options );
-       $dismissed = get_option( 'dismissed_update_core' );
-       if ( !is_array( $dismissed ) ) $dismissed = array();
-       $from_api = get_option( 'update_core' );
-       if ( empty($from_api) )
+       $options = array_merge( array( 'available' => true, 'dismissed' => false ), $options );
+       $dismissed = get_site_option( 'dismissed_update_core' );
+
+       if ( ! is_array( $dismissed ) )
+               $dismissed = array();
+
+       $from_api = get_site_transient( 'update_core' );
+
+       if ( ! isset( $from_api->updates ) || ! is_array( $from_api->updates ) )
                return false;
-       if ( !is_array( $from_api->updates ) ) return false;
+
        $updates = $from_api->updates;
-       if ( !is_array( $updates ) ) return false;
        $result = array();
-       foreach($updates as $update) {
-               if ( array_key_exists( $update->current.'|'.$update->locale, $dismissed ) ) {
+       foreach ( $updates as $update ) {
+               if ( $update->response == 'autoupdate' )
+                       continue;
+
+               if ( array_key_exists( $update->current . '|' . $update->locale, $dismissed ) ) {
                        if ( $options['dismissed'] ) {
                                $update->dismissed = true;
-                               $result[]= $update;
+                               $result[] = $update;
                        }
                } else {
                        if ( $options['available'] ) {
                                $update->dismissed = false;
-                               $result[]= $update;
+                               $result[] = $update;
                        }
                }
        }
        return $result;
 }
 
+/**
+ * Gets the best available (and enabled) Auto-Update for WordPress Core.
+ *
+ * If there's 1.2.3 and 1.3 on offer, it'll choose 1.3 if the install allows it, else, 1.2.3
+ *
+ * @since 3.7.0
+ *
+ * @return bool|array False on failure, otherwise the core update offering.
+ */
+function find_core_auto_update() {
+       $updates = get_site_transient( 'update_core' );
+       if ( ! $updates || empty( $updates->updates ) )
+               return false;
+
+       include_once ABSPATH . 'wp-admin/includes/class-wp-upgrader.php';
+
+       $auto_update = false;
+       $upgrader = new WP_Automatic_Updater;
+       foreach ( $updates->updates as $update ) {
+               if ( 'autoupdate' != $update->response )
+                       continue;
+
+               if ( ! $upgrader->should_update( 'core', $update, ABSPATH ) )
+                       continue;
+
+               if ( ! $auto_update || version_compare( $update->current, $auto_update->current, '>' ) )
+                       $auto_update = $update;
+       }
+       return $auto_update;
+}
+
+/**
+ * Gets and caches the checksums for the given version of WordPress.
+ *
+ * @since 3.7.0
+ *
+ * @param string $version Version string to query.
+ * @param string $locale  Locale to query.
+ * @return bool|array False on failure. An array of checksums on success.
+ */
+function get_core_checksums( $version, $locale ) {
+       $return = array();
+
+       $url = $http_url = 'http://api.wordpress.org/core/checksums/1.0/?' . http_build_query( compact( 'version', 'locale' ), null, '&' );
+
+       if ( $ssl = wp_http_supports( array( 'ssl' ) ) )
+               $url = set_url_scheme( $url, 'https' );
+
+       $options = array(
+               'timeout' => ( ( defined('DOING_CRON') && DOING_CRON ) ? 30 : 3 ),
+       );
+
+       $response = wp_remote_get( $url, $options );
+       if ( $ssl && is_wp_error( $response ) ) {
+               trigger_error( __( 'An unexpected error occurred. Something may be wrong with WordPress.org or this server&#8217;s configuration. If you continue to have problems, please try the <a href="http://wordpress.org/support/">support forums</a>.' ) . ' ' . '(WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.)', headers_sent() || WP_DEBUG ? E_USER_WARNING : E_USER_NOTICE );
+               $response = wp_remote_get( $http_url, $options );
+       }
+
+       if ( is_wp_error( $response ) || 200 != wp_remote_retrieve_response_code( $response ) )
+               return false;
+
+       $body = trim( wp_remote_retrieve_body( $response ) );
+       $body = json_decode( $body, true );
+
+       if ( ! is_array( $body ) || ! isset( $body['checksums'] ) || ! is_array( $body['checksums'] ) )
+               return false;
+
+       return $body['checksums'];
+}
+
 function dismiss_core_update( $update ) {
-       $dismissed = get_option( 'dismissed_update_core' );
-       $dismissed[ $update->current.'|'.$update->locale ] = true;
-       return update_option( 'dismissed_update_core', $dismissed );
+       $dismissed = get_site_option( 'dismissed_update_core' );
+       $dismissed[ $update->current . '|' . $update->locale ] = true;
+       return update_site_option( 'dismissed_update_core', $dismissed );
 }
 
 function undismiss_core_update( $version, $locale ) {
-       $dismissed = get_option( 'dismissed_update_core' );
-       $key = $version.'|'.$locale;
-       if ( !isset( $dismissed[$key] ) ) return false;
+       $dismissed = get_site_option( 'dismissed_update_core' );
+       $key = $version . '|' . $locale;
+
+       if ( ! isset( $dismissed[$key] ) )
+               return false;
+
        unset( $dismissed[$key] );
-       return update_option( 'dismissed_update_core', $dismissed );
+       return update_site_option( 'dismissed_update_core', $dismissed );
 }
 
 function find_core_update( $version, $locale ) {
-       $from_api = get_option( 'update_core' );
-       if ( !is_array( $from_api->updates ) ) return false;
+       $from_api = get_site_transient( 'update_core' );
+
+       if ( ! isset( $from_api->updates ) || ! is_array( $from_api->updates ) )
+               return false;
+
        $updates = $from_api->updates;
-       foreach($updates as $update) {
+       foreach ( $updates as $update ) {
                if ( $update->current == $version && $update->locale == $locale )
                        return $update;
        }
@@ -82,10 +162,13 @@ function find_core_update( $version, $locale ) {
 }
 
 function core_update_footer( $msg = '' ) {
-       if ( !current_user_can('manage_options') )
-               return sprintf( '| '.__( 'Version %s' ), $GLOBALS['wp_version'] );
+       if ( !current_user_can('update_core') )
+               return sprintf( __( 'Version %s' ), get_bloginfo( 'version', 'display' ) );
 
        $cur = get_preferred_from_update_core();
+       if ( ! is_object( $cur ) )
+               $cur = new stdClass;
+
        if ( ! isset( $cur->current ) )
                $cur->current = '';
 
@@ -97,24 +180,25 @@ function core_update_footer( $msg = '' ) {
 
        switch ( $cur->response ) {
        case 'development' :
-               return sprintf( __( 'You are using a development version (%1$s). Cool! Please <a href="%2$s">stay updated</a>.' ), $GLOBALS['wp_version'], 'update-core.php');
+               return sprintf( __( 'You are using a development version (%1$s). Cool! Please <a href="%2$s">stay updated</a>.' ), get_bloginfo( 'version', 'display' ), network_admin_url( 'update-core.php' ) );
        break;
 
        case 'upgrade' :
-               if ( current_user_can('manage_options') ) {
-                       return sprintf( '<strong>'.__( '<a href="%1$s">Get Version %2$s</a>' ).'</strong>', 'update-core.php', $cur->current);
-                       break;
-               }
+               return sprintf( '<strong>'.__( '<a href="%1$s">Get Version %2$s</a>' ).'</strong>', network_admin_url( 'update-core.php' ), $cur->current);
+       break;
 
        case 'latest' :
        default :
-               return sprintf( __( 'Version %s' ), $GLOBALS['wp_version'] );
+               return sprintf( __( 'Version %s' ), get_bloginfo( 'version', 'display' ) );
        break;
        }
 }
 add_filter( 'update_footer', 'core_update_footer' );
 
 function update_nag() {
+       if ( is_multisite() && !current_user_can('update_core') )
+               return false;
+
        global $pagenow;
 
        if ( 'update-core.php' == $pagenow )
@@ -125,368 +209,227 @@ function update_nag() {
        if ( ! isset( $cur->response ) || $cur->response != 'upgrade' )
                return false;
 
-       if ( current_user_can('manage_options') )
-               $msg = sprintf( __('WordPress %1$s is available! <a href="%2$s">Please update now</a>.'), $cur->current, 'update-core.php' );
-       else
-               $msg = sprintf( __('WordPress %1$s is available! Please notify the site administrator.'), $cur->current );
-
-       echo "<div id='update-nag'>$msg</div>";
+       if ( current_user_can('update_core') ) {
+               $msg = sprintf( __('<a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> is available! <a href="%2$s">Please update now</a>.'), $cur->current, network_admin_url( 'update-core.php' ) );
+       } else {
+               $msg = sprintf( __('<a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> is available! Please notify the site administrator.'), $cur->current );
+       }
+       echo "<div class='update-nag'>$msg</div>";
 }
 add_action( 'admin_notices', 'update_nag', 3 );
+add_action( 'network_admin_notices', 'update_nag', 3 );
 
 // Called directly from dashboard
 function update_right_now_message() {
-       $cur = get_preferred_from_update_core();
-
-       $msg = sprintf( __('You are using <span class="b">WordPress %s</span>.'), $GLOBALS['wp_version'] );
-       if ( isset( $cur->response ) && $cur->response == 'upgrade' && current_user_can('manage_options') )
-               $msg .= " <a href='update-core.php' class='button'>" . sprintf( __('Update to %s'), $cur->current ? $cur->current : __( 'Latest' ) ) . '</a>';
-
-       echo "<span id='wp-version-message'>$msg</span>";
-}
-
-function wp_plugin_update_row( $file, $plugin_data ) {
-       $current = get_option( 'update_plugins' );
-       if ( !isset( $current->response[ $file ] ) )
-               return false;
-
-       $r = $current->response[ $file ];
-
-       $details_url = admin_url('plugin-install.php?tab=plugin-information&plugin=' . $r->slug . '&TB_iframe=true&width=600&height=800');
-
-       echo '<tr><td colspan="5" class="plugin-update">';
-       if ( ! current_user_can('update_plugins') )
-               printf( __('There is a new version of %1$s available. <a href="%2$s" class="thickbox" title="%1$s">View version %3$s Details</a>.'), $plugin_data['Name'], $details_url, $r->new_version);
-       else if ( empty($r->package) )
-               printf( __('There is a new version of %1$s available. <a href="%2$s" class="thickbox" title="%1$s">View version %3$s Details</a> <em>automatic upgrade unavailable for this plugin</em>.'), $plugin_data['Name'], $details_url, $r->new_version);
-       else
-               printf( __('There is a new version of %1$s available. <a href="%2$s" class="thickbox" title="%1$s">View version %3$s Details</a> or <a href="%4$s">upgrade automatically</a>.'), $plugin_data['Name'], $details_url, $r->new_version, wp_nonce_url('update.php?action=upgrade-plugin&amp;plugin=' . $file, 'upgrade-plugin_' . $file) );
-
-       echo '</td></tr>';
-}
-add_action( 'after_plugin_row', 'wp_plugin_update_row', 10, 2 );
-
-function wp_update_plugin($plugin, $feedback = '') {
-       global $wp_filesystem;
-
-       if ( !empty($feedback) )
-               add_filter('update_feedback', $feedback);
-
-       // Is an update available?
-       $current = get_option( 'update_plugins' );
-       if ( !isset( $current->response[ $plugin ] ) )
-               return new WP_Error('up_to_date', __('The plugin is at the latest version.'));
-
-       // Is a filesystem accessor setup?
-       if ( ! $wp_filesystem || ! is_object($wp_filesystem) )
-               WP_Filesystem();
-
-       if ( ! is_object($wp_filesystem) )
-               return new WP_Error('fs_unavailable', __('Could not access filesystem.'));
-
-       if ( $wp_filesystem->errors->get_error_code() )
-               return new WP_Error('fs_error', __('Filesystem error'), $wp_filesystem->errors);
-
-       //Get the base plugin folder
-       $plugins_dir = $wp_filesystem->wp_plugins_dir();
-       if ( empty($plugins_dir) )
-               return new WP_Error('fs_no_plugins_dir', __('Unable to locate WordPress Plugin directory.'));
-
-       //And the same for the Content directory.
-       $content_dir = $wp_filesystem->wp_content_dir();
-       if( empty($content_dir) )
-               return new WP_Error('fs_no_content_dir', __('Unable to locate WordPress Content directory (wp-content).'));
+       $msg = sprintf( __( 'You are using <span class="b">WordPress %s</span>.' ), get_bloginfo( 'version', 'display' ) );
 
-       $plugins_dir = trailingslashit( $plugins_dir );
-       $content_dir = trailingslashit( $content_dir );
+       if ( current_user_can('update_core') ) {
+               $cur = get_preferred_from_update_core();
 
-       // Get the URL to the zip file
-       $r = $current->response[ $plugin ];
-
-       if ( empty($r->package) )
-               return new WP_Error('no_package', __('Upgrade package not available.'));
-
-       // Download the package
-       $package = $r->package;
-       apply_filters('update_feedback', sprintf(__('Downloading update from %s'), $package));
-       $download_file = download_url($package);
-
-       if ( is_wp_error($download_file) )
-               return new WP_Error('download_failed', __('Download failed.'), $download_file->get_error_message());
-
-       $working_dir = $content_dir . 'upgrade/' . basename($plugin, '.php');
-
-       // Clean up working directory
-       if ( $wp_filesystem->is_dir($working_dir) )
-               $wp_filesystem->delete($working_dir, true);
-
-       apply_filters('update_feedback', __('Unpacking the update'));
-       // Unzip package to working directory
-       $result = unzip_file($download_file, $working_dir);
-
-       // Once extracted, delete the package
-       unlink($download_file);
-
-       if ( is_wp_error($result) ) {
-               $wp_filesystem->delete($working_dir, true);
-               return $result;
-       }
-
-       if ( is_plugin_active($plugin) ) {
-               //Deactivate the plugin silently, Prevent deactivation hooks from running.
-               apply_filters('update_feedback', __('Deactivating the plugin'));
-               deactivate_plugins($plugin, true);
+               if ( isset( $cur->response ) && $cur->response == 'upgrade' )
+                       $msg .= " <a href='" . network_admin_url( 'update-core.php' ) . "' class='button'>" . sprintf( __('Update to %s'), $cur->current ? $cur->current : __( 'Latest' ) ) . '</a>';
        }
 
-       // Remove the existing plugin.
-       apply_filters('update_feedback', __('Removing the old version of the plugin'));
-       $this_plugin_dir = trailingslashit( dirname($plugins_dir . $plugin) );
-
-       // If plugin is in its own directory, recursively delete the directory.
-       if ( strpos($plugin, '/') && $this_plugin_dir != $plugins_dir ) //base check on if plugin includes directory seperator AND that its not the root plugin folder
-               $deleted = $wp_filesystem->delete($this_plugin_dir, true);
-       else
-               $deleted = $wp_filesystem->delete($plugins_dir . $plugin);
-
-       if ( ! $deleted ) {
-               $wp_filesystem->delete($working_dir, true);
-               return new WP_Error('delete_failed', __('Could not remove the old plugin'));
-       }
+       echo "<span id='wp-version-message'>$msg</span>";
+}
 
-       apply_filters('update_feedback', __('Installing the latest version'));
-       // Copy new version of plugin into place.
-       $result = copy_dir($working_dir, $plugins_dir);
-       if ( is_wp_error($result) ) {
-               $wp_filesystem->delete($working_dir, true);
-               return $result;
+function get_plugin_updates() {
+       $all_plugins = get_plugins();
+       $upgrade_plugins = array();
+       $current = get_site_transient( 'update_plugins' );
+       foreach ( (array)$all_plugins as $plugin_file => $plugin_data) {
+               if ( isset( $current->response[ $plugin_file ] ) ) {
+                       $upgrade_plugins[ $plugin_file ] = (object) $plugin_data;
+                       $upgrade_plugins[ $plugin_file ]->update = $current->response[ $plugin_file ];
+               }
        }
 
-       //Get a list of the directories in the working directory before we delete it, We need to know the new folder for the plugin
-       $filelist = array_keys( $wp_filesystem->dirlist($working_dir) );
-
-       // Remove working directory
-       $wp_filesystem->delete($working_dir, true);
-
-       // Force refresh of plugin update information
-       delete_option('update_plugins');
-
-       if( empty($filelist) )
-               return false; //We couldnt find any files in the working dir, therefor no plugin installed? Failsafe backup.
-
-       $folder = $filelist[0];
-       $plugin = get_plugins('/' . $folder); //Ensure to pass with leading slash
-       $pluginfiles = array_keys($plugin); //Assume the requested plugin is the first in the list
-
-       return  $folder . '/' . $pluginfiles[0];
+       return $upgrade_plugins;
 }
 
-function wp_update_theme($theme, $feedback = '') {
-       global $wp_filesystem;
-
-       if ( !empty($feedback) )
-               add_filter('update_feedback', $feedback);
-
-       // Is an update available?
-       $current = get_option( 'update_themes' );
-       if ( !isset( $current->response[ $theme ] ) )
-               return new WP_Error('up_to_date', __('The theme is at the latest version.'));
-
-       $r = $current->response[ $theme ];
+function wp_plugin_update_rows() {
+       if ( !current_user_can('update_plugins' ) )
+               return;
 
-       $themes = get_themes();
-       foreach ( (array) $themes as $this_theme ) {
-               if ( $this_theme['Stylesheet'] == $theme ) {
-                       $theme_directory = preg_replace('!^/themes/!i', '', $this_theme['Stylesheet Dir']);
-                       break;
+       $plugins = get_site_transient( 'update_plugins' );
+       if ( isset($plugins->response) && is_array($plugins->response) ) {
+               $plugins = array_keys( $plugins->response );
+               foreach( $plugins as $plugin_file ) {
+                       add_action( "after_plugin_row_$plugin_file", 'wp_plugin_update_row', 10, 2 );
                }
        }
-       unset($themes);
-
-       if ( empty($theme_directory) )
-               return new WP_Error('theme_non_existant', __('Theme does not exist.'));
-
-       // Is a filesystem accessor setup?
-       if ( ! $wp_filesystem || ! is_object($wp_filesystem) )
-               WP_Filesystem();
-
-       if ( ! is_object($wp_filesystem) )
-               return new WP_Error('fs_unavailable', __('Could not access filesystem.'));
-
-       if ( $wp_filesystem->errors->get_error_code() )
-               return new WP_Error('fs_error', __('Filesystem error'), $wp_filesystem->errors);
-
-       //Get the base plugin folder
-       $themes_dir = $wp_filesystem->wp_themes_dir();
-       if ( empty($themes_dir) )
-               return new WP_Error('fs_no_themes_dir', __('Unable to locate WordPress Theme directory.'));
-
-       //And the same for the Content directory.
-       $content_dir = $wp_filesystem->wp_content_dir();
-       if( empty($content_dir) )
-               return new WP_Error('fs_no_content_dir', __('Unable to locate WordPress Content directory (wp-content).'));
-
-       $themes_dir = trailingslashit( $themes_dir );
-       $content_dir = trailingslashit( $content_dir );
-
-       if ( empty($r->package) )
-               return new WP_Error('no_package', __('Upgrade package not available.'));
-
-       // Download the package
-       apply_filters('update_feedback', sprintf(__('Downloading update from %s'), $r['package']));
-       $download_file = download_url($r['package']);
-
-       if ( is_wp_error($download_file) )
-               return new WP_Error('download_failed', __('Download failed.'), $download_file->get_error_message());
-
-       $working_dir = $content_dir . 'upgrade/' . basename($theme_directory);
-
-       // Clean up working directory
-       if ( $wp_filesystem->is_dir($working_dir) )
-               $wp_filesystem->delete($working_dir, true);
-
-       apply_filters('update_feedback', __('Unpacking the update'));
-       // Unzip package to working directory
-       $result = unzip_file($download_file, $working_dir);
-
-       // Once extracted, delete the package
-       unlink($download_file);
+}
+add_action( 'admin_init', 'wp_plugin_update_rows' );
 
-       if ( is_wp_error($result) ) {
-               $wp_filesystem->delete($working_dir, true);
-               return $result;
-       }
+function wp_plugin_update_row( $file, $plugin_data ) {
+       $current = get_site_transient( 'update_plugins' );
+       if ( !isset( $current->response[ $file ] ) )
+               return false;
 
-       //TODO: Is theme currently active? If so, set default theme
-       /*
-       if ( is_plugin_active($plugin) ) {
-               //Deactivate the plugin silently, Prevent deactivation hooks from running.
-               apply_filters('update_feedback', __('Deactivating the plugin'));
-               deactivate_plugins($plugin, true);
-       }*/
-
-       // Remove the existing plugin.
-       apply_filters('update_feedback', __('Removing the old version of the theme'));
-       $deleted = $wp_filesystem->delete($themes_dir . $theme_directory, true);
-
-       if ( ! $deleted ) {
-               $wp_filesystem->delete($working_dir, true);
-               return new WP_Error('delete_failed', __('Could not remove the old plugin'));
-       }
+       $r = $current->response[ $file ];
 
-       apply_filters('update_feedback', __('Installing the latest version'));
-       // Copy new version of plugin into place.
-       $result = copy_dir($working_dir, $themes_dir);
-       if ( is_wp_error($result) ) {
-               $wp_filesystem->delete($working_dir, true);
-               return $result;
+       $plugins_allowedtags = array('a' => array('href' => array(),'title' => array()),'abbr' => array('title' => array()),'acronym' => array('title' => array()),'code' => array(),'em' => array(),'strong' => array());
+       $plugin_name = wp_kses( $plugin_data['Name'], $plugins_allowedtags );
+
+       $details_url = self_admin_url('plugin-install.php?tab=plugin-information&plugin=' . $r->slug . '&section=changelog&TB_iframe=true&width=600&height=800');
+
+       $wp_list_table = _get_list_table('WP_Plugins_List_Table');
+
+       if ( is_network_admin() || !is_multisite() ) {
+               echo '<tr class="plugin-update-tr"><td colspan="' . $wp_list_table->get_column_count() . '" class="plugin-update colspanchange"><div class="update-message">';
+
+               if ( ! current_user_can('update_plugins') )
+                       printf( __('There is a new version of %1$s available. <a href="%2$s" class="thickbox" title="%3$s">View version %4$s details</a>.'), $plugin_name, esc_url($details_url), esc_attr($plugin_name), $r->new_version );
+               else if ( empty($r->package) )
+                       printf( __('There is a new version of %1$s available. <a href="%2$s" class="thickbox" title="%3$s">View version %4$s details</a>. <em>Automatic update is unavailable for this plugin.</em>'), $plugin_name, esc_url($details_url), esc_attr($plugin_name), $r->new_version );
+               else
+                       printf( __('There is a new version of %1$s available. <a href="%2$s" class="thickbox" title="%3$s">View version %4$s details</a> or <a href="%5$s">update now</a>.'), $plugin_name, esc_url($details_url), esc_attr($plugin_name), $r->new_version, wp_nonce_url( self_admin_url('update.php?action=upgrade-plugin&plugin=') . $file, 'upgrade-plugin_' . $file) );
+
+               /**
+                * Fires at the end of the update message container in each
+                * row of the plugins list table.
+                *
+                * The dynamic portion of the hook name, $file, refers to the path
+                * of the plugin's primary file relative to the plugins directory.
+                *
+                * @since 2.8.0
+                *
+                * @param array $plugin_data {
+                *     An array of plugin metadata.
+                *
+                *     @type string $name         The human-readable name of the plugin.
+                *     @type string $plugin_uri   Plugin URI.
+                *     @type string $version      Plugin version.
+                *     @type string $description  Plugin description.
+                *     @type string $author       Plugin author.
+                *     @type string $author_uri   Plugin author URI.
+                *     @type string $text_domain  Plugin text domain.
+                *     @type string $domain_path  Relative path to the plugin's .mo file(s).
+                *     @type bool   $network      Whether the plugin can only be activated network wide.
+                *     @type string $title        The human-readable title of the plugin.
+                *     @type string $author_name  Plugin author's name.
+                *     @type bool   $update       Whether there's an available update. Default null.
+                * }
+                * @param array $r {
+                *     An array of metadata about the available plugin update.
+                *
+                *     @type int    $id           Plugin ID.
+                *     @type string $slug         Plugin slug.
+                *     @type string $new_version  New plugin version.
+                *     @type string $url          Plugin URL.
+                *     @type string $package      Plugin update package URL.
+                * }
+                */
+               do_action( "in_plugin_update_message-{$file}", $plugin_data, $r );
+
+               echo '</div></td></tr>';
        }
-
-       //Get a list of the directories in the working directory before we delete it, We need to know the new folder for the plugin
-       //$filelist = array_keys( $wp_filesystem->dirlist($working_dir) );
-
-       // Remove working directory
-       $wp_filesystem->delete($working_dir, true);
-
-       // Force refresh of plugin update information
-       delete_option('update_themes');
-
-       /*if( empty($filelist) )
-               return false; //We couldnt find any files in the working dir, therefor no plugin installed? Failsafe backup.
-
-       $folder = $filelist[0];
-       $plugin = get_plugins('/' . $folder); //Ensure to pass with leading slash
-       $pluginfiles = array_keys($plugin); //Assume the requested plugin is the first in the list
-
-       return  $folder . '/' . $pluginfiles[0];*/
 }
 
+function get_theme_updates() {
+       $themes = wp_get_themes();
+       $current = get_site_transient('update_themes');
 
-function wp_update_core($current, $feedback = '') {
-       global $wp_filesystem;
-
-       @set_time_limit( 300 );
-
-       if ( !empty($feedback) )
-               add_filter('update_feedback', $feedback);
-
-       // Is an update available?
-       if ( !isset( $current->response ) || $current->response == 'latest' )
-               return new WP_Error('up_to_date', __('WordPress is at the latest version.'));
+       if ( ! isset( $current->response ) )
+               return array();
 
-       // Is a filesystem accessor setup?
-       if ( ! $wp_filesystem || ! is_object($wp_filesystem) )
-               WP_Filesystem();
-
-       if ( ! is_object($wp_filesystem) )
-               return new WP_Error('fs_unavailable', __('Could not access filesystem.'));
-
-       if ( $wp_filesystem->errors->get_error_code() )
-               return new WP_Error('fs_error', __('Filesystem error'), $wp_filesystem->errors);
-
-       // Get the base WP folder
-       $wp_dir = $wp_filesystem->abspath();
-       if ( empty($wp_dir) )
-               return new WP_Error('fs_no_wp_dir', __('Unable to locate WordPress directory.'));
-
-       // And the same for the Content directory.
-       $content_dir = $wp_filesystem->wp_content_dir();
-       if( empty($content_dir) )
-               return new WP_Error('fs_no_content_dir', __('Unable to locate WordPress Content directory (wp-content).'));
-
-       $wp_dir = trailingslashit( $wp_dir );
-       $content_dir = trailingslashit( $content_dir );
+       $update_themes = array();
+       foreach ( $current->response as $stylesheet => $data ) {
+               $update_themes[ $stylesheet ] = wp_get_theme( $stylesheet );
+               $update_themes[ $stylesheet ]->update = $data;
+       }
 
-       // Get the URL to the zip file
-       $package = $current->package;
+       return $update_themes;
+}
 
-       // Download the package
-       apply_filters('update_feedback', sprintf(__('Downloading update from %s'), $package));
-       $download_file = download_url($package);
+function wp_theme_update_rows() {
+       if ( !current_user_can('update_themes' ) )
+               return;
 
-       if ( is_wp_error($download_file) )
-               return new WP_Error('download_failed', __('Download failed.'), $download_file->get_error_message());
+       $themes = get_site_transient( 'update_themes' );
+       if ( isset($themes->response) && is_array($themes->response) ) {
+               $themes = array_keys( $themes->response );
 
-       $working_dir = $content_dir . 'upgrade/core';
-       // Clean up working directory
-       if ( $wp_filesystem->is_dir($working_dir) ) {
-               $wp_filesystem->delete($working_dir, true);
+               foreach( $themes as $theme ) {
+                       add_action( "after_theme_row_$theme", 'wp_theme_update_row', 10, 2 );
+               }
        }
+}
+add_action( 'admin_init', 'wp_theme_update_rows' );
 
-       apply_filters('update_feedback', __('Unpacking the core update'));
-       // Unzip package to working directory
-       $result = unzip_file($download_file, $working_dir);
-       // Once extracted, delete the package
-       unlink($download_file);
-
-       if ( is_wp_error($result) ) {
-               $wp_filesystem->delete($working_dir, true);
-               return $result;
-       }
+function wp_theme_update_row( $theme_key, $theme ) {
+       $current = get_site_transient( 'update_themes' );
+       if ( !isset( $current->response[ $theme_key ] ) )
+               return false;
+       $r = $current->response[ $theme_key ];
+       $themes_allowedtags = array('a' => array('href' => array(),'title' => array()),'abbr' => array('title' => array()),'acronym' => array('title' => array()),'code' => array(),'em' => array(),'strong' => array());
+       $theme_name = wp_kses( $theme['Name'], $themes_allowedtags );
 
-       // Copy update-core.php from the new version into place.
-       if ( !$wp_filesystem->copy($working_dir . '/wordpress/wp-admin/includes/update-core.php', $wp_dir . 'wp-admin/includes/update-core.php', true) ) {
-               $wp_filesystem->delete($working_dir, true);
-               return new WP_Error('copy_failed', __('Could not copy files'));
-       }
-       $wp_filesystem->chmod($wp_dir . 'wp-admin/includes/update-core.php', FS_CHMOD_FILE);
+       $details_url = add_query_arg( array( 'TB_iframe' => 'true', 'width' => 1024, 'height' => 800 ), $current->response[ $theme_key ]['url'] );
 
-       require(ABSPATH . 'wp-admin/includes/update-core.php');
+       $wp_list_table = _get_list_table('WP_MS_Themes_List_Table');
 
-       return update_core($working_dir, $wp_dir);
+       echo '<tr class="plugin-update-tr"><td colspan="' . $wp_list_table->get_column_count() . '" class="plugin-update colspanchange"><div class="update-message">';
+       if ( ! current_user_can('update_themes') )
+               printf( __('There is a new version of %1$s available. <a href="%2$s" class="thickbox" title="%3$s">View version %4$s details</a>.'), $theme['Name'], esc_url($details_url), esc_attr($theme['Name']), $r->new_version );
+       else if ( empty( $r['package'] ) )
+               printf( __('There is a new version of %1$s available. <a href="%2$s" class="thickbox" title="%3$s">View version %4$s details</a>. <em>Automatic update is unavailable for this theme.</em>'), $theme['Name'], esc_url($details_url), esc_attr($theme['Name']), $r['new_version'] );
+       else
+               printf( __('There is a new version of %1$s available. <a href="%2$s" class="thickbox" title="%3$s">View version %4$s details</a> or <a href="%5$s">update now</a>.'), $theme['Name'], esc_url($details_url), esc_attr($theme['Name']), $r['new_version'], wp_nonce_url( self_admin_url('update.php?action=upgrade-theme&theme=') . $theme_key, 'upgrade-theme_' . $theme_key) );
+
+       /**
+        * Fires at the end of the update message container in each
+        * row of the themes list table.
+        *
+        * The dynamic portion of the hook name, $theme_key, refers to
+        * the theme slug as found in the WordPress.org themes repository.
+        *
+        * @since 3.1.0
+        *
+        * @param WP_Theme $theme The WP_Theme object.
+        * @param array    $r {
+        *     An array of metadata about the available theme update.
+        *
+        *     @type string $new_version New theme version.
+        *     @type string $url         Theme URL.
+        *     @type string $package     Theme update package URL.
+        * }
+        */
+       do_action( "in_theme_update_message-{$theme_key}", $theme, $r );
+
+       echo '</div></td></tr>';
 }
 
 function maintenance_nag() {
+       include ABSPATH . WPINC . '/version.php'; // include an unmodified $wp_version
        global $upgrading;
-       if ( ! isset( $upgrading ) )
+       $nag = isset( $upgrading );
+       if ( ! $nag ) {
+               $failed = get_site_option( 'auto_core_update_failed' );
+               /*
+                * If an update failed critically, we may have copied over version.php but not other files.
+                * In that case, if the install claims we're running the version we attempted, nag.
+                * This is serious enough to err on the side of nagging.
+                *
+                * If we simply failed to update before we tried to copy any files, then assume things are
+                * OK if they are now running the latest.
+                *
+                * This flag is cleared whenever a successful update occurs using Core_Upgrader.
+                */
+               $comparison = ! empty( $failed['critical'] ) ? '>=' : '>';
+               if ( version_compare( $failed['attempted'], $wp_version, $comparison ) )
+                       $nag = true;
+       }
+
+       if ( ! $nag )
                return false;
 
-       if ( current_user_can('manage_options') )
+       if ( current_user_can('update_core') )
                $msg = sprintf( __('An automated WordPress update has failed to complete - <a href="%s">please attempt the update again now</a>.'), 'update-core.php' );
        else
                $msg = __('An automated WordPress update has failed to complete! Please notify the site administrator.');
 
-       echo "<div id='update-nag'>$msg</div>";
+       echo "<div class='update-nag'>$msg</div>";
 }
 add_action( 'admin_notices', 'maintenance_nag' );
-
-?>
+add_action( 'network_admin_notices', 'maintenance_nag' );