WordPress 4.6.3
[autoinstalls/wordpress.git] / wp-content / themes / twentyfourteen / inc / back-compat.php
1 <?php
2 /**
3  * Twenty Fourteen back compat functionality
4  *
5  * Prevents Twenty Fourteen from running on WordPress versions prior to 3.6,
6  * since this theme is not meant to be backward compatible beyond that
7  * and relies on many newer functions and markup changes introduced in 3.6.
8  *
9  * @package WordPress
10  * @subpackage Twenty_Fourteen
11  * @since Twenty Fourteen 1.0
12  */
13
14 /**
15  * Prevent switching to Twenty Fourteen on old versions of WordPress.
16  *
17  * Switches to the default theme.
18  *
19  * @since Twenty Fourteen 1.0
20  */
21 function twentyfourteen_switch_theme() {
22         switch_theme( WP_DEFAULT_THEME, WP_DEFAULT_THEME );
23         unset( $_GET['activated'] );
24         add_action( 'admin_notices', 'twentyfourteen_upgrade_notice' );
25 }
26 add_action( 'after_switch_theme', 'twentyfourteen_switch_theme' );
27
28 /**
29  * Add message for unsuccessful theme switch.
30  *
31  * Prints an update nag after an unsuccessful attempt to switch to
32  * Twenty Fourteen on WordPress versions prior to 3.6.
33  *
34  * @since Twenty Fourteen 1.0
35  */
36 function twentyfourteen_upgrade_notice() {
37         $message = sprintf( __( 'Twenty Fourteen requires at least WordPress version 3.6. You are running version %s. Please upgrade and try again.', 'twentyfourteen' ), $GLOBALS['wp_version'] );
38         printf( '<div class="error"><p>%s</p></div>', $message );
39 }
40
41 /**
42  * Prevent the Customizer from being loaded on WordPress versions prior to 3.6.
43  *
44  * @since Twenty Fourteen 1.0
45  */
46 function twentyfourteen_customize() {
47         wp_die( sprintf( __( 'Twenty Fourteen requires at least WordPress version 3.6. You are running version %s. Please upgrade and try again.', 'twentyfourteen' ), $GLOBALS['wp_version'] ), '', array(
48                 'back_link' => true,
49         ) );
50 }
51 add_action( 'load-customize.php', 'twentyfourteen_customize' );
52
53 /**
54  * Prevent the Theme Preview from being loaded on WordPress versions prior to 3.4.
55  *
56  * @since Twenty Fourteen 1.0
57  */
58 function twentyfourteen_preview() {
59         if ( isset( $_GET['preview'] ) ) {
60                 wp_die( sprintf( __( 'Twenty Fourteen requires at least WordPress version 3.6. You are running version %s. Please upgrade and try again.', 'twentyfourteen' ), $GLOBALS['wp_version'] ) );
61         }
62 }
63 add_action( 'template_redirect', 'twentyfourteen_preview' );